Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

Use default printer settings

Discussion in 'Information Technology' started by Jürg Leuenberger, Nov 4, 2005.

  1. Jürg Leuenberger

    Jürg Leuenberger
    Expand Collapse
    Guest

    Hello all,
    I have a problem where I can't find a solution. I hope that some
    knowledgable and helpful soul can help:
    I create my FE/BE DBs and in there many reports. Attached is my default
    printer with my personal default settings (like duplex, paper tray, color,
    ....). Now these settings seem to get saved IN the reports.
    when I distribute the FE in the company, the reports are printed on the
    default printers of the clients (which are often different ones than mine),
    so that works. But they always use my printer settings. So for people who
    prefer to print single sided (and have their printer set up accordingly)
    still get double sided print outs. Or even worse for pepole using different
    paper sizes (e.g. US-Letter) the printer still asks to load A4.

    How do I tell Access to always use the default printer AND THE DEFAULT
    PRINTER SETTINGS?

    I know that the people could open the reports in design view, save them and
    it would be ok. But first that is not an option since I distribute the FE as
    MDE, and second there MUST be another way around this.

    PS: I am using ACC2k3, the clients are using both ACC2k and ACC2k3
     
  2. Loading...


  3. Allen Browne

    Allen Browne
    Expand Collapse
    Guest

    1. Make sure the Name AutoCorrect boxes are unchecked under:
    Tools | Options | General.
    For an explanation, see:
    http://allenbrowne.com/bug-03.html

    2. In report design view, make sure *you* have set the report to use the
    Default printer under:
    File | Page Setup | Page.

    3. Make sure your margins + report width are less than the narrower paper
    (e.g. 8.27 inch for A4, not 8.5 for Letter, or in landscape mode, 11 inch
    for Letter, not 11.667 inch for A4.)

    The report will now print on A4 or Letter, using the default printer
    settings.

    --
    Allen Browne - Microsoft MVP. Perth, Western Australia.
    Tips for Access users - http://allenbrowne.com/tips.html
    Reply to group, rather than allenbrowne at mvps dot org.

    "Jürg Leuenberger" <JrgLeuenberger@discussions.microsoft.com> wrote in
    message
    news:14ECF1C0-079A-4A16-9F56-7286C5AC470F@microsoft.com...
    > Hello all,
    > I have a problem where I can't find a solution. I hope that some
    > knowledgable and helpful soul can help:
    > I create my FE/BE DBs and in there many reports. Attached is my default
    > printer with my personal default settings (like duplex, paper tray, color,
    > ...). Now these settings seem to get saved IN the reports.
    > when I distribute the FE in the company, the reports are printed on the
    > default printers of the clients (which are often different ones than
    > mine),
    > so that works. But they always use my printer settings. So for people who
    > prefer to print single sided (and have their printer set up accordingly)
    > still get double sided print outs. Or even worse for pepole using
    > different
    > paper sizes (e.g. US-Letter) the printer still asks to load A4.
    >
    > How do I tell Access to always use the default printer AND THE DEFAULT
    > PRINTER SETTINGS?
    >
    > I know that the people could open the reports in design view, save them
    > and
    > it would be ok. But first that is not an option since I distribute the FE
    > as
    > MDE, and second there MUST be another way around this.
    >
    > PS: I am using ACC2k3, the clients are using both ACC2k and ACC2k3
     
  4. Jürg Leuenberger

    Jürg Leuenberger
    Expand Collapse
    Guest

    Allen
    Thanks for your reply. However, it does still not work as you suggest.
    NameAutoCorrect is off
    Default Printer is set for report
    I print with my current default printer settings -> I get double sided print
    out
    Close Access
    I go into System/Printers, change the default printer setting to single
    sided (uncheck the duplex option)
    I reopen my DB, print report again -> still double sided print out

    Any other thoughts?

    George

    "Allen Browne" wrote:

    > 1. Make sure the Name AutoCorrect boxes are unchecked under:
    > Tools | Options | General.
    > For an explanation, see:
    > http://allenbrowne.com/bug-03.html
    >
    > 2. In report design view, make sure *you* have set the report to use the
    > Default printer under:
    > File | Page Setup | Page.
    >
    > 3. Make sure your margins + report width are less than the narrower paper
    > (e.g. 8.27 inch for A4, not 8.5 for Letter, or in landscape mode, 11 inch
    > for Letter, not 11.667 inch for A4.)
    >
    > The report will now print on A4 or Letter, using the default printer
    > settings.
    >
    > --
    > Allen Browne - Microsoft MVP. Perth, Western Australia.
    > Tips for Access users - http://allenbrowne.com/tips.html
    > Reply to group, rather than allenbrowne at mvps dot org.
    >
    > "Jürg Leuenberger" <JrgLeuenberger@discussions.microsoft.com> wrote in
    > message
    > news:14ECF1C0-079A-4A16-9F56-7286C5AC470F@microsoft.com...
    > > Hello all,
    > > I have a problem where I can't find a solution. I hope that some
    > > knowledgable and helpful soul can help:
    > > I create my FE/BE DBs and in there many reports. Attached is my default
    > > printer with my personal default settings (like duplex, paper tray, color,
    > > ...). Now these settings seem to get saved IN the reports.
    > > when I distribute the FE in the company, the reports are printed on the
    > > default printers of the clients (which are often different ones than
    > > mine),
    > > so that works. But they always use my printer settings. So for people who
    > > prefer to print single sided (and have their printer set up accordingly)
    > > still get double sided print outs. Or even worse for pepole using
    > > different
    > > paper sizes (e.g. US-Letter) the printer still asks to load A4.
    > >
    > > How do I tell Access to always use the default printer AND THE DEFAULT
    > > PRINTER SETTINGS?
    > >
    > > I know that the people could open the reports in design view, save them
    > > and
    > > it would be ok. But first that is not an option since I distribute the FE
    > > as
    > > MDE, and second there MUST be another way around this.
    > >
    > > PS: I am using ACC2k3, the clients are using both ACC2k and ACC2k3

    >
    >
    >
     
  5. Allen Browne

    Allen Browne
    Expand Collapse
    Guest

    If Access is failing to respect the printer setting for double-siding, it is
    possible that there is a problem with the way it interacts with this
    printer, but it is more likely that this is a problem with the printer
    driver.

    If any other readers have experienced Accesss-specific problems with
    double-sided printing, please post your experience.

    --
    Allen Browne - Microsoft MVP. Perth, Western Australia.
    Tips for Access users - http://allenbrowne.com/tips.html
    Reply to group, rather than allenbrowne at mvps dot org.

    "Jürg Leuenberger" <JrgLeuenberger@discussions.microsoft.com> wrote in
    message
    news:602C8A49-8E14-42B6-BA97-EF088949FD09@microsoft.com...
    > Allen
    > Thanks for your reply. However, it does still not work as you suggest.
    > NameAutoCorrect is off
    > Default Printer is set for report
    > I print with my current default printer settings -> I get double sided
    > print
    > out
    > Close Access
    > I go into System/Printers, change the default printer setting to single
    > sided (uncheck the duplex option)
    > I reopen my DB, print report again -> still double sided print out
    >
    > Any other thoughts?
    >
    > George
    >
    > "Allen Browne" wrote:
    >
    >> 1. Make sure the Name AutoCorrect boxes are unchecked under:
    >> Tools | Options | General.
    >> For an explanation, see:
    >> http://allenbrowne.com/bug-03.html
    >>
    >> 2. In report design view, make sure *you* have set the report to use the
    >> Default printer under:
    >> File | Page Setup | Page.
    >>
    >> 3. Make sure your margins + report width are less than the narrower paper
    >> (e.g. 8.27 inch for A4, not 8.5 for Letter, or in landscape mode, 11 inch
    >> for Letter, not 11.667 inch for A4.)
    >>
    >> The report will now print on A4 or Letter, using the default printer
    >> settings.
    >>
    >> "Jürg Leuenberger" <JrgLeuenberger@discussions.microsoft.com> wrote in
    >> message
    >> news:14ECF1C0-079A-4A16-9F56-7286C5AC470F@microsoft.com...
    >> > Hello all,
    >> > I have a problem where I can't find a solution. I hope that some
    >> > knowledgable and helpful soul can help:
    >> > I create my FE/BE DBs and in there many reports. Attached is my default
    >> > printer with my personal default settings (like duplex, paper tray,
    >> > color,
    >> > ...). Now these settings seem to get saved IN the reports.
    >> > when I distribute the FE in the company, the reports are printed on the
    >> > default printers of the clients (which are often different ones than
    >> > mine),
    >> > so that works. But they always use my printer settings. So for people
    >> > who
    >> > prefer to print single sided (and have their printer set up
    >> > accordingly)
    >> > still get double sided print outs. Or even worse for pepole using
    >> > different
    >> > paper sizes (e.g. US-Letter) the printer still asks to load A4.
    >> >
    >> > How do I tell Access to always use the default printer AND THE DEFAULT
    >> > PRINTER SETTINGS?
    >> >
    >> > I know that the people could open the reports in design view, save them
    >> > and
    >> > it would be ok. But first that is not an option since I distribute the
    >> > FE
    >> > as
    >> > MDE, and second there MUST be another way around this.
    >> >
    >> > PS: I am using ACC2k3, the clients are using both ACC2k and ACC2k3
     
  6. Jürg Leuenberger

    Jürg Leuenberger
    Expand Collapse
    Guest

    I doubt that it is the printer driver, because I actually tried it with
    several different printers as my default printer.

    It would be great to hear from other people who have the same problem. Or if
    I am the only one, well that would mean that I need to find out why.

    Does this mean that the same procedure actually works for you? You change
    the default printer settings in your System/Printers directory and the Access
    report actually do follow suit?

    "Allen Browne" wrote:

    > If Access is failing to respect the printer setting for double-siding, it is
    > possible that there is a problem with the way it interacts with this
    > printer, but it is more likely that this is a problem with the printer
    > driver.
    >
    > If any other readers have experienced Accesss-specific problems with
    > double-sided printing, please post your experience.
    >
    > --
    > Allen Browne - Microsoft MVP. Perth, Western Australia.
    > Tips for Access users - http://allenbrowne.com/tips.html
    > Reply to group, rather than allenbrowne at mvps dot org.
    >
    > "Jürg Leuenberger" <JrgLeuenberger@discussions.microsoft.com> wrote in
    > message
    > news:602C8A49-8E14-42B6-BA97-EF088949FD09@microsoft.com...
    > > Allen
    > > Thanks for your reply. However, it does still not work as you suggest.
    > > NameAutoCorrect is off
    > > Default Printer is set for report
    > > I print with my current default printer settings -> I get double sided
    > > print
    > > out
    > > Close Access
    > > I go into System/Printers, change the default printer setting to single
    > > sided (uncheck the duplex option)
    > > I reopen my DB, print report again -> still double sided print out
    > >
    > > Any other thoughts?
    > >
    > > George
    > >
    > > "Allen Browne" wrote:
    > >
    > >> 1. Make sure the Name AutoCorrect boxes are unchecked under:
    > >> Tools | Options | General.
    > >> For an explanation, see:
    > >> http://allenbrowne.com/bug-03.html
    > >>
    > >> 2. In report design view, make sure *you* have set the report to use the
    > >> Default printer under:
    > >> File | Page Setup | Page.
    > >>
    > >> 3. Make sure your margins + report width are less than the narrower paper
    > >> (e.g. 8.27 inch for A4, not 8.5 for Letter, or in landscape mode, 11 inch
    > >> for Letter, not 11.667 inch for A4.)
    > >>
    > >> The report will now print on A4 or Letter, using the default printer
    > >> settings.
    > >>
    > >> "Jürg Leuenberger" <JrgLeuenberger@discussions.microsoft.com> wrote in
    > >> message
    > >> news:14ECF1C0-079A-4A16-9F56-7286C5AC470F@microsoft.com...
    > >> > Hello all,
    > >> > I have a problem where I can't find a solution. I hope that some
    > >> > knowledgable and helpful soul can help:
    > >> > I create my FE/BE DBs and in there many reports. Attached is my default
    > >> > printer with my personal default settings (like duplex, paper tray,
    > >> > color,
    > >> > ...). Now these settings seem to get saved IN the reports.
    > >> > when I distribute the FE in the company, the reports are printed on the
    > >> > default printers of the clients (which are often different ones than
    > >> > mine),
    > >> > so that works. But they always use my printer settings. So for people
    > >> > who
    > >> > prefer to print single sided (and have their printer set up
    > >> > accordingly)
    > >> > still get double sided print outs. Or even worse for pepole using
    > >> > different
    > >> > paper sizes (e.g. US-Letter) the printer still asks to load A4.
    > >> >
    > >> > How do I tell Access to always use the default printer AND THE DEFAULT
    > >> > PRINTER SETTINGS?
    > >> >
    > >> > I know that the people could open the reports in design view, save them
    > >> > and
    > >> > it would be ok. But first that is not an option since I distribute the
    > >> > FE
    > >> > as
    > >> > MDE, and second there MUST be another way around this.
    > >> >
    > >> > PS: I am using ACC2k3, the clients are using both ACC2k and ACC2k3

    >
    >
    >
     
  7. Allen Browne

    Allen Browne
    Expand Collapse
    Guest

    None of my printers use double-siding.

    --
    Allen Browne - Microsoft MVP. Perth, Western Australia.
    Tips for Access users - http://allenbrowne.com/tips.html
    Reply to group, rather than allenbrowne at mvps dot org.

    "Jürg Leuenberger" <JrgLeuenberger@discussions.microsoft.com> wrote in
    message
    news:C294C00D-8BCA-40F2-8211-42D88A2CF6B2@microsoft.com...
    >
    > Does this mean that the same procedure actually works for you?
     
  8. Lydia

    Lydia
    Expand Collapse
    Guest

    I have the exact same problem with distributing databases to users. I am
    currently updating databases and I just imported all my objects into a new
    Access database for testing. Half of the reports use the defined defaults,
    half are printing to the wrong tray. There MUST be some way of dealing with
    this but I haven't found it yet! Let me know if you do!
    --
    Lydia


    "Jürg Leuenberger" wrote:

    > Hello all,
    > I have a problem where I can't find a solution. I hope that some
    > knowledgable and helpful soul can help:
    > I create my FE/BE DBs and in there many reports. Attached is my default
    > printer with my personal default settings (like duplex, paper tray, color,
    > ...). Now these settings seem to get saved IN the reports.
    > when I distribute the FE in the company, the reports are printed on the
    > default printers of the clients (which are often different ones than mine),
    > so that works. But they always use my printer settings. So for people who
    > prefer to print single sided (and have their printer set up accordingly)
    > still get double sided print outs. Or even worse for pepole using different
    > paper sizes (e.g. US-Letter) the printer still asks to load A4.
    >
    > How do I tell Access to always use the default printer AND THE DEFAULT
    > PRINTER SETTINGS?
    >
    > I know that the people could open the reports in design view, save them and
    > it would be ok. But first that is not an option since I distribute the FE as
    > MDE, and second there MUST be another way around this.
    >
    > PS: I am using ACC2k3, the clients are using both ACC2k and ACC2k3
     

Share This Page