Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

the object doesn't contain Automation object '|.'

Discussion in 'Information Technology' started by Gary.Crider@gmail.com, Jul 28, 2006.

  1. Gary.Crider@gmail.com

    Gary.Crider@gmail.com
    Expand Collapse
    Guest

    When i am trying to export a report to an excel file i am getting this
    error: The object doesn't contain automation object '|.' I get to this
    report through a button that is located on the main menu form. How
    ever if i open this report from the database window under reports, then
    export, I will not run into any problems, it works like a dream. I
    have no idea where this is coming from, I do not have any tables or
    queries labeled like this. I was put into the middle of this database
    and do not see any VBA code that has a '|' in it. I may have just not
    found it yet. I am not sure if that is the real problem or not.

    Does anyone know why this would act like this? What should i be
    looking for? Am i close to being on the right track? Any suggestions
    would be helpful.

    Thanks in advance.
     
  2. Loading...


  3. NetworkTrade

    NetworkTrade
    Expand Collapse
    Guest

    If I understand your question; it is the button that is not working.

    Can you build a new button that does it - and then simply delete the old?
    --
    NTC


    "Gary.Crider@gmail.com" wrote:

    > When i am trying to export a report to an excel file i am getting this
    > error: The object doesn't contain automation object '|.' I get to this
    > report through a button that is located on the main menu form. How
    > ever if i open this report from the database window under reports, then
    > export, I will not run into any problems, it works like a dream. I
    > have no idea where this is coming from, I do not have any tables or
    > queries labeled like this. I was put into the middle of this database
    > and do not see any VBA code that has a '|' in it. I may have just not
    > found it yet. I am not sure if that is the real problem or not.
    >
    > Does anyone know why this would act like this? What should i be
    > looking for? Am i close to being on the right track? Any suggestions
    > would be helpful.
    >
    > Thanks in advance.
    >
    >
     
  4. Gary.Crider@gmail.com

    Gary.Crider@gmail.com
    Expand Collapse
    Guest

    I acutally do not have an export button, I should, but for now i have
    to go to the File -> Export to do this. I have not yet been able to
    uncover any code that was set up prior to me working in this database,
    and I don't know if it is just a problem with access trying to export.
    Or if there is code somewhere that I have not found. any other
    suggestions. Or would creating a button take care of this?
     
  5. NetworkTrade

    NetworkTrade
    Expand Collapse
    Guest

    so if the Report is opened via the button - it will not export....

    yet if you open the Report not via the button - it will export....

    That is not something I have ever seen - sorry maybe another can fix -
    obviously you have found a work-around by opening it without the button.
    And my first suggestion of creating a new button to open the Report also may
    work too - but it is also a work-around....

    I have also not (yet) built an automated export button so can't throw any
    pre-made code at you - sorry to be so unhelpful on this one
    --
    NTC


    "Gary.Crider@gmail.com" wrote:

    > I acutally do not have an export button, I should, but for now i have
    > to go to the File -> Export to do this. I have not yet been able to
    > uncover any code that was set up prior to me working in this database,
    > and I don't know if it is just a problem with access trying to export.
    > Or if there is code somewhere that I have not found. any other
    > suggestions. Or would creating a button take care of this?
    >
    >
     

Share This Page