Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!
  1.   Become a Supporter    ::   Make a Contribution   
    Target (Recurring Monthly): $200 :: Achieved: $98

Switchboard&Linking Problem? Help Please..

Discussion in 'Information Technology' started by WCDoan, Jul 28, 2006.

  1. WCDoan

    WCDoan
    Expand Collapse
    Guest

    I have created a database and have split it. Have had to make some additions
    to the front end. Added a program and when I run it it works fine. However, I
    need to add it to the switchboard. I went into the Switchboard Manager and
    added an item for the new program. However, when I run the program from the
    swithboard it bombs, but if I run it by itself, again it works fine. Anyone
    have any ideas what could be causing this? If I'm running the same program,
    why does it work in one place and not the next? Help, please.
    Thanks,
    RandyM
     
  2. Loading...

    Similar Threads Forum Date
    Sikh News Sikhs Face Problems While Carrying Kirpans In Khyber-Pakhtunkhwa - SikhSiyasat.Net Breaking News Jul 29, 2016
    "Dasam" Granth - A Look At The Core Problems Dasam Granth Oct 21, 2015
    Problems In Life Sikh Sikhi Sikhism Apr 13, 2015
    How can I make decent and useful friends and from where ?? most people have a problem with me Sikh Youth Oct 23, 2013
    The Problem with Taking Too Many Vitamins Health & Nutrition Oct 18, 2013

  3. WCDoan

    WCDoan
    Expand Collapse
    Guest

    Here's a little more info on the problem. The error message is
    Runtime error 3075
    Syntax error(missing operator) in query expression '[OwnerID_AnimalTbl]='

    When I debug it yellows out on the CountOfAnimals statement:
    Private Sub Owner_AfterUpdate()
    ' Find the record that matches the control.
    Dim rs As Object
    Set rs = Me.Recordset.Clone
    rs.FindFirst "[OwnerID] = " & Str(Nz(Me![Owner], 0))
    If Not rs.EOF Then Me.Bookmark = rs.Bookmark
    CountOfAnimals = DCount("*", "tblAnimals", "[OwnerID_AnimalTbl] = " &
    Me.OwnerID)
    End Sub

    I have no idea where to look since it works fine when I run it outside the
    Switchboard. I'm at a loss, which is not that unusual for me.:)

    Thanks for any help offered
    RandyM
    "WCDoan" wrote:

    > I have created a database and have split it. Have had to make some additions
    > to the front end. Added a program and when I run it it works fine. However, I
    > need to add it to the switchboard. I went into the Switchboard Manager and
    > added an item for the new program. However, when I run the program from the
    > swithboard it bombs, but if I run it by itself, again it works fine. Anyone
    > have any ideas what could be causing this? If I'm running the same program,
    > why does it work in one place and not the next? Help, please.
    > Thanks,
    > RandyM
     
Since you're here... we have a small favor to ask...

More people are visiting & reading SPN than ever but far fewer are paying to sustain it. Advertising revenues across the online media have fallen fast. So you can see why we need to ask for your help. Donating to SPN's is vote for free speech, for diversity of opinions, for the right of the people to stand up to religious bigotry. Without any affiliation to any organization, this constant struggle takes a lot of hard work to sustain as we entirely depend on the contributions of our esteemed writers/readers. We do it because we believe our perspective matters – because it might well be your perspective, too... Fund our efforts and together we can keep the world informed about the real Sikh Sikhi Sikhism. If everyone who writes or reads our content, who likes it, helps us to pay for it, our future would be much more secure. Every Contribution Matters, Contribute Generously!

    Become a Supporter      ::     Make a Contribution     



Share This Page