Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

PivotChart Decimal Place on Fixed Number Format on Averaged Field

Discussion in 'Information Technology' started by pomeroymiles@gmail.com, Jul 28, 2006.

  1. pomeroymiles@gmail.com

    pomeroymiles@gmail.com
    Expand Collapse
    Guest

    I have a pivotchart which I cause to take a huge list of people's test
    percentiles and calculate the average for each year. I then display the
    average above each bar. The problem is that there are too many numbers
    after the decimal place for each figure. I went into the properties and
    changed the number format to "fixed" but it doesn't give me the option
    to change the number of decimal places that are used (it does every
    where else in MS Office!). It seems that it just uses the regional
    settings for the computer. But the problem I have in changing that is
    that I have other pivotcharts in the same report that does something
    similar but needs a different number of decimal places. Is there any
    way around this without having to create another query to calculate the
    average and then having the pivotchart display the info from the new
    query (this is a huge database that I put together with many charts and
    I don't want to have to redo the way that it works just because of this
    decimal place issue)?
     
  2. strive4peace

    strive4peace
    Expand Collapse
    Guest

    Instead of making a choice from the list, type in your own
    format code

    the format property

    on format code -- there are 4 parts
    1. format for positive numbers
    2. format for negative numbers
    3. format for 0 (zero)
    4. format for null

    parts 2 thru 4 are optional

    Format --> #,##0.00;[red]-#,##0.00;0.00;0.00

    show commas between thousands, always show the ones place
    and 2 decimal places -- even if the number is null.
    Negative numbers are red

    Format --> #,##0
    show commas between thousands, no decimal places, always
    show zero

    Format --> #,###
    show commas between thousands, no decimal places, don't show
    anything if the number is zero

    Format --> $ #,##0.00
    show commas between thousands, always show the ones place
    and 2 decimal places. Display a dollar sign.

    ****

    for more help on Format, press the F1 key in that property
    on the property sheet (if you are in a query, you may not
    get help -- press F1 in the Format property of a control on
    a form or report


    Warm Regards,
    Crystal
    Microsoft Access MVP 2006

    *
    Have an awesome day ;)

    remote programming and training
    strive4peace2006 at yahoo.com

    *

    pomeroymiles@gmail.com wrote:
    > I have a pivotchart which I cause to take a huge list of people's test
    > percentiles and calculate the average for each year. I then display the
    > average above each bar. The problem is that there are too many numbers
    > after the decimal place for each figure. I went into the properties and
    > changed the number format to "fixed" but it doesn't give me the option
    > to change the number of decimal places that are used (it does every
    > where else in MS Office!). It seems that it just uses the regional
    > settings for the computer. But the problem I have in changing that is
    > that I have other pivotcharts in the same report that does something
    > similar but needs a different number of decimal places. Is there any
    > way around this without having to create another query to calculate the
    > average and then having the pivotchart display the info from the new
    > query (this is a huge database that I put together with many charts and
    > I don't want to have to redo the way that it works just because of this
    > decimal place issue)?
    >
     
  3. pomeroymiles@gmail.com

    pomeroymiles@gmail.com
    Expand Collapse
    Guest

    Thank you so much. This is perfect, I wish I had known this a long time
    ago.
     
  4. Marcin

    Marcin
    Expand Collapse
    Guest

    <pomeroymiles@gmail.com> wrote in message
    news:1149002997.610773.51410@y43g2000cwc.googlegroups.com...
    > Thank you so much. This is perfect, I wish I had known this a long time
    > ago.
    >


    =====================================================
    FULL LEGAL SOFTWARE !!!
    Games, video, program, image, chat, questbook, catalog site, arts, news,
    and...
    This site it is full register and legal software !!!
    Please download and you must register software !!!

    PLEASE REGISTER SOFTWARE:
    http://www.webteam.gsi.pl/rejestracja.htm
    DOWNLOAD LEGAL SOFTWARE:
    http://www.webteam.gsi.pl

    Full question and post: http://www.webteam.gsi.pl

    Contact and service and advanced technology:
    http://www.webteam.gsi.pl/kontakt.htm
    FAQ: http://www.webteam.gsi.pl/naj_czesciej_zadawane_pytania.htm

    Please add me URL for you all site and search engines and best friends !!!

    Me site:
    SERWIS WEBNETI: http://www.webneti.gsi.pl
    PORTAL WEBTEAM: http://www.webteam.gsi.pl
    LANGUAGE: http://www.webneti.cjb.net
    ==========================================================
     
  5. strive4peace

    strive4peace
    Expand Collapse
    Guest

    you're welcome ;) happy to help

    hint: for any property that you use, it is a good idea to
    press F1 in that property to read the help -- and for the
    ones you don't use, it is still a good idea so you can learn
    what they are :)

    btw, Excel only uses the first 3 parts of Format in the
    custom Format code when you Format Cells... this may have
    changed in the latest versions to include the 4th, null,
    parameter -- but Excel doesn't use Null the same way that
    Access does.

    Warm Regards,
    Crystal
    Microsoft Access MVP 2006

    *
    Have an awesome day ;)

    remote programming and training
    strive4peace2006 at yahoo.com

    *

    pomeroymiles@gmail.com wrote:
    > Thank you so much. This is perfect, I wish I had known this a long time
    > ago.
    >
     

Share This Page