Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

Picture won't stay inserted

Discussion in 'Information Technology' started by Robert, Jul 28, 2006.

  1. Robert

    Robert
    Expand Collapse
    Guest

    I figured out how to add a picture to my frmEmployee using the tblEmployee
    with the field "Picture"....type = OLE Object.
    Works just beautifully, including seeing pictures on the report = rptEmployee
    However, when I try to add a new employee's picture...1. I added the new
    ..jpeg to the external folder "Employee Pics". 2. I opened the
    frmEmployee...entered basic table data, e.g. name, place of work, address,
    etc...tabbed over to picture, selected INSERT from menu, then selected
    Windows Word Picture, which opened the WORD doc picture edit area; then
    selected INSERT again...found the picture in the external file C:\Employee
    Pics and double clicked on the .jpeg. Then went back in to the ACCESS
    frmEmployee, waited about 30 secs and the picture was there. I then added
    some more data...went to another file, but when i returned, this employee's
    picture had DISAPPEARED! What happened? I have had this happend to 6 new
    employee pictures. They are all .jpeg and added to the exact same folder
    where the remainder of the employee pictures are located. WHY do they go away?

    Robert navcporetrt@cox.net
     
  2. Loading...

    Similar Threads Forum Date
    Sikh News In Pictures: Hundreds Of Youngsters Attend Sikh Summer Camp - Slough Express Breaking News Aug 13, 2016
    Events Collection Of Rare Historical Pictures From British India History of Sikhism Mar 10, 2015
    Opinion West Punjab : Information Pool and Pictures Punjab, Punjabi, Punjabiyat Nov 18, 2013
    Heritage Now a Vegetable Market, Ranjit Singh's Royal Haveli a Picture of Neglect History of Sikhism Nov 11, 2013
    Inspirational Pictures - Yes, Why? Inspirational Stories Oct 28, 2013

  3. Wayne-I-M

    Wayne-I-M
    Expand Collapse
    Guest

    Hi Robert,

    As this question get's asked so many time I have made this cut-n-paste.
    Hope it helps you along the right direction. You are not linking your photos
    so and that may be why the are not staying in place.

    Have a look at this and see if you can get some ideas

    Wayne


    Make copies of the pictures you want to link to your records (on C Drive /
    hard disk) and save them as
    ThumbnailPicture1,
    ThumbnailPicture2,
    ThumbnailPicture3,
    etc , (or use the ID of the record in the table)

    If you have a picture processing programme such as Photoshop or Photopaint
    then use that to resample and convert. If you don’t have one of these
    programmes:

    1 Click start
    2 Click My Pictures (if that’s where they are)
    3 Right click the picture and select “Open Withâ€
    4 Select Windows Office Picture Manager
    5 After the picture is open click the Picture Menu then select Resize
    6 Resize your picture to the correct size
    NOTE. You will need to know the pixel size of your OLE box (ie.
    57pixels =
    2cm) To get this go back to the D Base and open the
    properties box.
    7 SaveAS a copy of the original (DON’T JUST SAVE or you will ruin the
    original picture)

    Create an OLE field in the table (use this OLE field on your form if you
    wish to display the picture on a form with a particular record)

    To link your pictur thumbnail with the OLE
    8 Open the Table that will hold the data /picture (not the form)
    9 navigate to the OLE field on the correct record and Right Click
    10 Select Insert Object
    11 Select Create From File and then Bitmap and then check the Link option
    12 Browse to your picture and select it
    13 Click OK
    14 “Package†will appear in the field
    15 View your image on the form

    Hope this helps and points you in the right direction










    "Robert" wrote:

    > I figured out how to add a picture to my frmEmployee using the tblEmployee
    > with the field "Picture"....type = OLE Object.
    > Works just beautifully, including seeing pictures on the report = rptEmployee
    > However, when I try to add a new employee's picture...1. I added the new
    > .jpeg to the external folder "Employee Pics". 2. I opened the
    > frmEmployee...entered basic table data, e.g. name, place of work, address,
    > etc...tabbed over to picture, selected INSERT from menu, then selected
    > Windows Word Picture, which opened the WORD doc picture edit area; then
    > selected INSERT again...found the picture in the external file C:\Employee
    > Pics and double clicked on the .jpeg. Then went back in to the ACCESS
    > frmEmployee, waited about 30 secs and the picture was there. I then added
    > some more data...went to another file, but when i returned, this employee's
    > picture had DISAPPEARED! What happened? I have had this happend to 6 new
    > employee pictures. They are all .jpeg and added to the exact same folder
    > where the remainder of the employee pictures are located. WHY do they go away?
    >
    > Robert navcporetrt@cox.net
     
  4. Robert

    Robert
    Expand Collapse
    Guest

    Sir,
    I am using ACCESS 2000 and can not find Windows Office Picture manager. Is
    there another file I can use like PAINT?
    I am anxious to try to follow these directions.
    The db is currently 1 g and is at work...won't fit on my 1 g thumbdrive to
    allow me to change it here (home), but will get back in touch with you.

    Thanks,
    RT

    "Wayne-I-M" wrote:

    > Hi Robert,
    >
    > As this question get's asked so many time I have made this cut-n-paste.
    > Hope it helps you along the right direction. You are not linking your photos
    > so and that may be why the are not staying in place.
    >
    > Have a look at this and see if you can get some ideas
    >
    > Wayne
    >
    >
    > Make copies of the pictures you want to link to your records (on C Drive /
    > hard disk) and save them as
    > ThumbnailPicture1,
    > ThumbnailPicture2,
    > ThumbnailPicture3,
    > etc , (or use the ID of the record in the table)
    >
    > If you have a picture processing programme such as Photoshop or Photopaint
    > then use that to resample and convert. If you don’t have one of these
    > programmes:
    >
    > 1 Click start
    > 2 Click My Pictures (if that’s where they are)
    > 3 Right click the picture and select “Open Withâ€
    > 4 Select Windows Office Picture Manager
    > 5 After the picture is open click the Picture Menu then select Resize
    > 6 Resize your picture to the correct size
    > NOTE. You will need to know the pixel size of your OLE box (ie.
    > 57pixels =
    > 2cm) To get this go back to the D Base and open the
    > properties box.
    > 7 SaveAS a copy of the original (DON’T JUST SAVE or you will ruin the
    > original picture)
    >
    > Create an OLE field in the table (use this OLE field on your form if you
    > wish to display the picture on a form with a particular record)
    >
    > To link your pictur thumbnail with the OLE
    > 8 Open the Table that will hold the data /picture (not the form)
    > 9 navigate to the OLE field on the correct record and Right Click
    > 10 Select Insert Object
    > 11 Select Create From File and then Bitmap and then check the Link option
    > 12 Browse to your picture and select it
    > 13 Click OK
    > 14 “Package†will appear in the field
    > 15 View your image on the form
    >
    > Hope this helps and points you in the right direction
    >
    >
    >
    >
    >
    >
    >
    >
    >
    >
    > "Robert" wrote:
    >
    > > I figured out how to add a picture to my frmEmployee using the tblEmployee
    > > with the field "Picture"....type = OLE Object.
    > > Works just beautifully, including seeing pictures on the report = rptEmployee
    > > However, when I try to add a new employee's picture...1. I added the new
    > > .jpeg to the external folder "Employee Pics". 2. I opened the
    > > frmEmployee...entered basic table data, e.g. name, place of work, address,
    > > etc...tabbed over to picture, selected INSERT from menu, then selected
    > > Windows Word Picture, which opened the WORD doc picture edit area; then
    > > selected INSERT again...found the picture in the external file C:\Employee
    > > Pics and double clicked on the .jpeg. Then went back in to the ACCESS
    > > frmEmployee, waited about 30 secs and the picture was there. I then added
    > > some more data...went to another file, but when i returned, this employee's
    > > picture had DISAPPEARED! What happened? I have had this happend to 6 new
    > > employee pictures. They are all .jpeg and added to the exact same folder
    > > where the remainder of the employee pictures are located. WHY do they go away?
    > >
    > > Robert navcporetrt@cox.net
     

Share This Page