Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

Multiple User Access to a database

Discussion in 'Information Technology' started by Ken Mechail, Jul 28, 2006.

  1. Ken Mechail

    Ken Mechail
    Expand Collapse
    Guest

    Greetings,

    I have a situation at work.

    There is a shared database (Access 2003) stored on a network drive.

    For most of the users, more than one person can access the database
    simultaneously. But for one particular user, SOMETIMES when he is in the
    database, no one else can get in.

    Any suggestions?

    Thank you
    Ken
     
  2. Loading...


  3. Jerry Whittle

    Jerry Whittle
    Expand Collapse
    Guest

    1. All users of the database must have read, write, create, and delete
    privileges to the network folder holding the database file. Not just the
    database .mdb file, but the entire folder.

    2. Open the database and go to Tools, Options, and Advanced Tab. Set the
    Default Open mode to Shared and the Default Record Locking to Edited Record.
    (While you are in the Options area, go over to the General tab and turn off
    Compact on Close and Name AutoCorrect. Trust me on this.)

    3. You can also get this error if someone has a form, report, etc., opened
    in design view. Early versions of Access would allow someone to make design
    changes while others are using the database; however, newer versions limit
    this ability. It's another good reason to split the database so that you can
    do development on a copy of the Front End and put it into production easily.
    Sure beats working midnight shift when the users aren't around!

    4. It’s possible that someone has manually opened the database exclusively.
    In that case go to the folder holding the .mdb file and open up the same
    named .ldb file in Notepad. You might be able to read which users are in the
    database and locked it. Apply 2â€x4†as necessary to user. However that should
    give a "file already in use" error. To stop this from happening create a
    shortcut for each user on their desktop or off the Start button. It should
    list the target as the database file and look something like:
    "P:\Databases\Database File.mdb"
    --
    Jerry Whittle
    Light. Strong. Cheap. Pick two. Keith Bontrager - Bicycle Builder.


    "Ken Mechail" wrote:

    > Greetings,
    >
    > I have a situation at work.
    >
    > There is a shared database (Access 2003) stored on a network drive.
    >
    > For most of the users, more than one person can access the database
    > simultaneously. But for one particular user, SOMETIMES when he is in the
    > database, no one else can get in.
    >
    > Any suggestions?
    >
    > Thank you
    > Ken
    >
     
  4. Ken Mechail

    Ken Mechail
    Expand Collapse
    Guest

    Thank you,

    I'll check those out


    "Jerry Whittle" wrote:

    > 1. All users of the database must have read, write, create, and delete
    > privileges to the network folder holding the database file. Not just the
    > database .mdb file, but the entire folder.
    >
    > 2. Open the database and go to Tools, Options, and Advanced Tab. Set the
    > Default Open mode to Shared and the Default Record Locking to Edited Record.
    > (While you are in the Options area, go over to the General tab and turn off
    > Compact on Close and Name AutoCorrect. Trust me on this.)
    >
    > 3. You can also get this error if someone has a form, report, etc., opened
    > in design view. Early versions of Access would allow someone to make design
    > changes while others are using the database; however, newer versions limit
    > this ability. It's another good reason to split the database so that you can
    > do development on a copy of the Front End and put it into production easily.
    > Sure beats working midnight shift when the users aren't around!
    >
    > 4. It’s possible that someone has manually opened the database exclusively.
    > In that case go to the folder holding the .mdb file and open up the same
    > named .ldb file in Notepad. You might be able to read which users are in the
    > database and locked it. Apply 2â€x4†as necessary to user. However that should
    > give a "file already in use" error. To stop this from happening create a
    > shortcut for each user on their desktop or off the Start button. It should
    > list the target as the database file and look something like:
    > "P:\Databases\Database File.mdb"
    > --
    > Jerry Whittle
    > Light. Strong. Cheap. Pick two. Keith Bontrager - Bicycle Builder.
    >
    >
    > "Ken Mechail" wrote:
    >
    > > Greetings,
    > >
    > > I have a situation at work.
    > >
    > > There is a shared database (Access 2003) stored on a network drive.
    > >
    > > For most of the users, more than one person can access the database
    > > simultaneously. But for one particular user, SOMETIMES when he is in the
    > > database, no one else can get in.
    > >
    > > Any suggestions?
    > >
    > > Thank you
    > > Ken
    > >
     
  5. Roger Carlson

    Roger Carlson
    Expand Collapse
    Guest

    Check his network rights to the DIRECTORY where the database is stored. He
    should have ALL rights including Read, Write, Modify and Delete. If he does
    not, if he opens it FIRST, everyone else will be locked out. This has to do
    with his inablility to create the LDB file.

    --
    --Roger Carlson
    MS Access MVP
    Access Database Samples: www.rogersaccesslibrary.com
    Want answers to your Access questions in your Email?
    Free subscription:
    http://peach.ease.lsoft.com/scripts/wa.exe?SUBED1=ACCESS-L


    "Ken Mechail" <KenMechail@discussions.microsoft.com> wrote in message
    news:DC0D6CBA-97D2-4CA4-AC32-072B6E7D2550@microsoft.com...
    > Greetings,
    >
    > I have a situation at work.
    >
    > There is a shared database (Access 2003) stored on a network drive.
    >
    > For most of the users, more than one person can access the database
    > simultaneously. But for one particular user, SOMETIMES when he is in the
    > database, no one else can get in.
    >
    > Any suggestions?
    >
    > Thank you
    > Ken
    >
     

Share This Page