Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!
  1.   Become a Supporter    ::   Make a Contribution   
    Target (Recurring Monthly): $200 :: Achieved: $98

Listview Object problem

Discussion in 'Information Technology' started by zulander@gmail.com, Jul 28, 2006.

  1. zulander@gmail.com

    zulander@gmail.com
    Expand Collapse
    Guest

    Hi i am having problem with the MS windows Common Control 6.0
    the problem is i have added my object in the form that i am using and
    it is working however when it's time to do some coding i am not seeing
    any classes listed
    for example if i type listview0 and the dot i should get the list of
    all classes right however i am not getting the list of all classes i am
    geting the properties (i.e: About, application backcolor etc..)

    so does anyone know if it's fixable thank you
     
  2. Loading...


  3. datAdrenaline

    datAdrenaline
    Expand Collapse
    Guest

    When you say you do not see any classes, what do you mean? You will not see
    a "Class" module for a ListView object ... Do you mean that you do not get
    the "autofill" drop downs when writing your code? To get the auto dropdowns,
    you need to first create a list view object reference in your code, then set
    it to the listview object on your form. Try out something like the sample
    code below, to see if this helps you out:

    Private Sub GetLVFillIns()

    Dim lv As ListView

    Set lv = Me.ListViewControlObjectNameOnForm.Object

    'Now that the list view object is 'Known' to the code through the
    reference
    'You can now use the contansts an method of a ListView control ..
    lv.Appearance = cc3D
    lv.Checkboxes = True
    lv.ColumnHeaders.Add , "MyHeaderKey", "MyColumnText"
    ... Etc ...
    End Sub

    (Note: COMPLETE AIR CODE! ... basically just hints to get you started!)

    --
    Regards,
    Brent Spaulding
    datAdrenaline


    "zulander@gmail.com" wrote:

    > Hi i am having problem with the MS windows Common Control 6.0
    > the problem is i have added my object in the form that i am using and
    > it is working however when it's time to do some coding i am not seeing
    > any classes listed
    > for example if i type listview0 and the dot i should get the list of
    > all classes right however i am not getting the list of all classes i am
    > geting the properties (i.e: About, application backcolor etc..)
    >
    > so does anyone know if it's fixable thank you
    >
    >
     
Since you're here... we have a small favor to ask...

More people are visiting & reading SPN than ever but far fewer are paying to sustain it. Advertising revenues across the online media have fallen fast. So you can see why we need to ask for your help. Donating to SPN's is vote for free speech, for diversity of opinions, for the right of the people to stand up to religious bigotry. Without any affiliation to any organization, this constant struggle takes a lot of hard work to sustain as we entirely depend on the contributions of our esteemed writers/readers. We do it because we believe our perspective matters – because it might well be your perspective, too... Fund our efforts and together we can keep the world informed about the real Sikh Sikhi Sikhism. If everyone who writes or reads our content, who likes it, helps us to pay for it, our future would be much more secure. Every Contribution Matters, Contribute Generously!

    Become a Supporter      ::     Make a Contribution     



Share This Page