Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

Linked Tables Error - "File Already in Use"

Discussion in 'Information Technology' started by Ken Mitchell, Jul 28, 2006.

  1. Ken Mitchell

    Ken Mitchell
    Expand Collapse
    Guest

    I've got an Access 2003 DB which I have split in to front-end and back-end
    databases using the Database Splitter. The backend (with all the tables) is
    on the server, in a shared directory with full control. The front-end (with
    the forms, querys and reports) is located on the Desktop. Any one user can
    open the front end DB - but no one else can. The next user gets the error
    message "Could not use <database path and name >; File already in use".

    It looks like the backend DB is being opened exclusively, but since the
    front end was linked to the back end using the Linked Tables Manager, I don't
    think that should be happening.

    This is a new install of Access 2003 on new WinXP box at a client site, and
    this has never been a problem before - but there's a first time for
    everything, I guess.

    There's something that I need to tweak - but it isn't obvious what.

    Thanks.
     
  2. Loading...

    Similar Threads Forum Date
    Opinion Letter: When terrorism is falsely linked by race or religion, we all become the victims Breaking News Apr 27, 2013
    SciTech Law of Entropy Linked to Evolution of Intelligence Breaking News Apr 23, 2013
    Canada GM corn linked to early death in new study Breaking News Sep 22, 2012
    India set to ban 100 Al Qaeda-linked groups Hard Talk May 17, 2010
    Sikh News Temple linked to terrorists still active (Moldova.org) Breaking News Feb 5, 2008

  3. Jerry Whittle

    Jerry Whittle
    Expand Collapse
    Guest

    Tools, Options, Advanced tab. What's it say on both the FE and BE under
    Default Open Mode and Default Record Locking?

    Are you sure that the FE is on the desktop or maybe is it a shortcut to the
    FE?
    --
    Jerry Whittle
    Light. Strong. Cheap. Pick two. Keith Bontrager - Bicycle Builder.


    "Ken Mitchell" wrote:

    > I've got an Access 2003 DB which I have split in to front-end and back-end
    > databases using the Database Splitter. The backend (with all the tables) is
    > on the server, in a shared directory with full control. The front-end (with
    > the forms, querys and reports) is located on the Desktop. Any one user can
    > open the front end DB - but no one else can. The next user gets the error
    > message "Could not use <database path and name >; File already in use".
    >
    > It looks like the backend DB is being opened exclusively, but since the
    > front end was linked to the back end using the Linked Tables Manager, I don't
    > think that should be happening.
    >
    > This is a new install of Access 2003 on new WinXP box at a client site, and
    > this has never been a problem before - but there's a first time for
    > everything, I guess.
    >
    > There's something that I need to tweak - but it isn't obvious what.
    >
    > Thanks.
     
  4. Ken Mitchell

    Ken Mitchell
    Expand Collapse
    Guest

    Thanks for the quick response, Jerry. One client has the FE on the desktop,
    another has the client in their "My Documents" directory with a shortcut on
    the desktop. Each client has his/her own FE database. There will be a total
    of five users once this gets straightened out.

    Under Tools, Options, Advanced, I have Default Open Mode - Shared, Default
    record Locking - Edited Record, and "open databases using record-level
    locking" is selected. That was the second thing I thought of. (The first was
    permissions on the BE directory, but I was pretty sure I'd set THAT
    right....)

    Anything else I can check? Thanks.

    "Jerry Whittle" wrote:

    > Tools, Options, Advanced tab. What's it say on both the FE and BE under
    > Default Open Mode and Default Record Locking?
    >
    > Are you sure that the FE is on the desktop or maybe is it a shortcut to the
    > FE?
    > --
    > Jerry Whittle
    > Light. Strong. Cheap. Pick two. Keith Bontrager - Bicycle Builder.
    >
    >
    > "Ken Mitchell" wrote:
    >
    > > I've got an Access 2003 DB which I have split in to front-end and back-end
    > > databases using the Database Splitter. The backend (with all the tables) is
    > > on the server, in a shared directory with full control. The front-end (with
    > > the forms, querys and reports) is located on the Desktop. Any one user can
    > > open the front end DB - but no one else can. The next user gets the error
    > > message "Could not use <database path and name >; File already in use".
    > >
    > > It looks like the backend DB is being opened exclusively, but since the
    > > front end was linked to the back end using the Linked Tables Manager, I don't
    > > think that should be happening.
    > >
    > > This is a new install of Access 2003 on new WinXP box at a client site, and
    > > this has never been a problem before - but there's a first time for
    > > everything, I guess.
    > >
    > > There's something that I need to tweak - but it isn't obvious what.
    > >
    > > Thanks.
     
  5. Ken Mitchell

    Ken Mitchell
    Expand Collapse
    Guest

    OK, a friend has helped me solve the problem. Her explanation: it's a
    permissions issue. In Win Server 2003, permissions, she says, aren't
    inherited like they used to be in older versions. My BE database was in a
    subfolder in a folder. I had explicitly set "Full Control" permissions on
    the parent folder, but had assumed (and what does the word "ASSUME" mean?
    Anyone? ) that the subfolder would have those same permissions. Since the
    subfolder apparently didn't have "create" rights, the BE database wasn't able
    to create the .LDB file, which forced Access to open the BE database in
    "exclusive" mode.

    Now that I have explicitly set "Full Control" permissions on the actual
    Database folder, both users (and presumably, others when I install the FE)
    can hit the database. And my problem appears to be solved. Thanks for
    everyone who gave this any thought at all.

    "Ken Mitchell" wrote:

    > Thanks for the quick response, Jerry. One client has the FE on the desktop,
    > another has the client in their "My Documents" directory with a shortcut on
    > the desktop. Each client has his/her own FE database. There will be a total
    > of five users once this gets straightened out.
    >
    > Under Tools, Options, Advanced, I have Default Open Mode - Shared, Default
    > record Locking - Edited Record, and "open databases using record-level
    > locking" is selected. That was the second thing I thought of. (The first was
    > permissions on the BE directory, but I was pretty sure I'd set THAT
    > right....)
    >
    > Anything else I can check? Thanks.
    >
    > "Jerry Whittle" wrote:
    >
    > > Tools, Options, Advanced tab. What's it say on both the FE and BE under
    > > Default Open Mode and Default Record Locking?
    > >
    > > Are you sure that the FE is on the desktop or maybe is it a shortcut to the
    > > FE?
    > > --
    > > Jerry Whittle
    > > Light. Strong. Cheap. Pick two. Keith Bontrager - Bicycle Builder.
    > >
    > >
    > > "Ken Mitchell" wrote:
    > >
    > > > I've got an Access 2003 DB which I have split in to front-end and back-end
    > > > databases using the Database Splitter. The backend (with all the tables) is
    > > > on the server, in a shared directory with full control. The front-end (with
    > > > the forms, querys and reports) is located on the Desktop. Any one user can
    > > > open the front end DB - but no one else can. The next user gets the error
    > > > message "Could not use <database path and name >; File already in use".
    > > >
    > > > It looks like the backend DB is being opened exclusively, but since the
    > > > front end was linked to the back end using the Linked Tables Manager, I don't
    > > > think that should be happening.
    > > >
    > > > This is a new install of Access 2003 on new WinXP box at a client site, and
    > > > this has never been a problem before - but there's a first time for
    > > > everything, I guess.
    > > >
    > > > There's something that I need to tweak - but it isn't obvious what.
    > > >
    > > > Thanks.
     
  6. Pieter Wijnen

    Pieter Wijnen
    Expand Collapse
    Guest

    Is a .ldb created along with the BE
    If not there's either insufficient rights to create files in the BE
    directory - or it is opened in exclusive mode

    Pieter

    "Ken Mitchell" <Kenwd0elq(NOSPAM)@gmail.com> wrote in message
    news:36D353F6-DF44-43DE-96A4-3C404F0C5976@microsoft.com...
    > Thanks for the quick response, Jerry. One client has the FE on the
    > desktop,
    > another has the client in their "My Documents" directory with a shortcut
    > on
    > the desktop. Each client has his/her own FE database. There will be a
    > total
    > of five users once this gets straightened out.
    >
    > Under Tools, Options, Advanced, I have Default Open Mode - Shared, Default
    > record Locking - Edited Record, and "open databases using record-level
    > locking" is selected. That was the second thing I thought of. (The first
    > was
    > permissions on the BE directory, but I was pretty sure I'd set THAT
    > right....)
    >
    > Anything else I can check? Thanks.
    >
    > "Jerry Whittle" wrote:
    >
    >> Tools, Options, Advanced tab. What's it say on both the FE and BE under
    >> Default Open Mode and Default Record Locking?
    >>
    >> Are you sure that the FE is on the desktop or maybe is it a shortcut to
    >> the
    >> FE?
    >> --
    >> Jerry Whittle
    >> Light. Strong. Cheap. Pick two. Keith Bontrager - Bicycle Builder.
    >>
    >>
    >> "Ken Mitchell" wrote:
    >>
    >> > I've got an Access 2003 DB which I have split in to front-end and
    >> > back-end
    >> > databases using the Database Splitter. The backend (with all the
    >> > tables) is
    >> > on the server, in a shared directory with full control. The front-end
    >> > (with
    >> > the forms, querys and reports) is located on the Desktop. Any one user
    >> > can
    >> > open the front end DB - but no one else can. The next user gets the
    >> > error
    >> > message "Could not use <database path and name >; File already in use".
    >> >
    >> > It looks like the backend DB is being opened exclusively, but since the
    >> > front end was linked to the back end using the Linked Tables Manager, I
    >> > don't
    >> > think that should be happening.
    >> >
    >> > This is a new install of Access 2003 on new WinXP box at a client site,
    >> > and
    >> > this has never been a problem before - but there's a first time for
    >> > everything, I guess.
    >> >
    >> > There's something that I need to tweak - but it isn't obvious what.
    >> >
    >> > Thanks.




    --
    ----------------------------------------
    I am using the free version of SPAMfighter for private users.
    It has removed 4079 spam emails to date.
    Paying users do not have this message in their emails.
    Get the free SPAMfighter here: http://www.spamfighter.com/len
     
  7. Ken Mitchell

    Ken Mitchell
    Expand Collapse
    Guest

    Thanks, Pieter. It turned out to be the first, that I had not assigned the
    appropriate permissions to that folder.

    I appreciate the response.

    "Pieter Wijnen" wrote:

    > Is a .ldb created along with the BE
    > If not there's either insufficient rights to create files in the BE
    > directory - or it is opened in exclusive mode
    >
    > Pieter
    >
     

Share This Page