Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

How to fix autonumber field which does not function?

Discussion in 'Information Technology' started by archivist, Jul 28, 2006.

  1. archivist

    archivist
    Expand Collapse
    Guest

    After converting a database created in an earlier version of access, I'm
    unable to continue to enter new records using my key indicator field which is
    an autonumber field. Instead of each record increasing by "1," the
    autonumber enters negative values such as -2153. Any thoughts?
     
  2. Loading...

    Similar Threads Forum Date
    Can Guru Sahib change our 'bhaag' (destiny/fortune) or we have to live with it ? is it fixed Sikh Sikhi Sikhism Oct 8, 2015
    Save Your Sanity for Less (Financial Fix Video) Business, Lifestyle & Leisure Jan 15, 2014
    Build Your Own Sikh Art Exhibit: Call for SPN Members to Fix a Problem! Sikh Youth Oct 17, 2013
    India Four Men Convicted in Rape Case That Transfixed India Breaking News Sep 10, 2013
    Opinion Human Evolution: No Easy Fix Breaking News Oct 5, 2011

  3. Ofer Cohen

    Ofer Cohen
    Expand Collapse
    Guest

    First BackUp your data, and then try to run Compact on And Repair to your MDB
    where the table is located on

    --
    Good Luck
    BS"D


    "archivist" wrote:

    > After converting a database created in an earlier version of access, I'm
    > unable to continue to enter new records using my key indicator field which is
    > an autonumber field. Instead of each record increasing by "1," the
    > autonumber enters negative values such as -2153. Any thoughts?
     
  4. Allen Browne

    Allen Browne
    Expand Collapse
    Guest

    See:
    Fixing AutoNumbers when Access assigns negatives or duplicates
    at:
    http://allenbrowne.com/ser-40.html

    --
    Allen Browne - Microsoft MVP. Perth, Western Australia.
    Tips for Access users - http://allenbrowne.com/tips.html
    Reply to group, rather than allenbrowne at mvps dot org.

    "archivist" <archivist@discussions.microsoft.com> wrote in message
    news:4B6B40A2-570E-41E0-9DE9-5DB7B54FFE48@microsoft.com...
    > After converting a database created in an earlier version of access, I'm
    > unable to continue to enter new records using my key indicator field which
    > is
    > an autonumber field. Instead of each record increasing by "1," the
    > autonumber enters negative values such as -2153. Any thoughts?
     

Share This Page