Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

Debugging

Discussion in 'Information Technology' started by PeterM, Oct 28, 2005.

Tags:
  1. PeterM

    PeterM
    Expand Collapse
    Guest

    I have a .mdb that I created in Access 2003 using 2002 database format on
    another machine. I've now got to edit the database using Access 2002 on my
    current machine.

    The problem is that I can't run debug mode. Whenever I place a breakpoint
    on a line of code and open the form, the Visual Basic window does not open
    and show the breakpoint so I can step through the remaining code.

    Am I missing a setting somewhere, I've been thru References, Options, etc.
    everywhere i can think of...please help!
     
  2. Ofer

    Ofer
    Expand Collapse
    Guest

    What happen, does the form still running, or does the code stop but you can't
    see the actual code break?

    You can try and put
    stop
    To break the code in a certain line, instead of a code break.
    Just don't forget to remove it when you finish
    --
    If I answered your question, please mark it as an answer. That way, it will
    stay saved for a longer time, so other can benifit from it.

    Good luck



    "PeterM" wrote:

    > I have a .mdb that I created in Access 2003 using 2002 database format on
    > another machine. I've now got to edit the database using Access 2002 on my
    > current machine.
    >
    > The problem is that I can't run debug mode. Whenever I place a breakpoint
    > on a line of code and open the form, the Visual Basic window does not open
    > and show the breakpoint so I can step through the remaining code.
    >
    > Am I missing a setting somewhere, I've been thru References, Options, etc.
    > everywhere i can think of...please help!
     
  3. PeterM

    PeterM
    Expand Collapse
    Guest

    The code does not stop....I have the following code assigned to a button

    Private Sub Command441_Click()
    Stop
    MsgBox "kdkdk"
    DoCmd.SetWarnings False
    Dim stDocName As String
    Dim stLinkCriteria As String
    stDocName = "broswer_display"
    DoCmd.OpenForm stDocName, , , stLinkCriteria
    DoCmd.SetWarnings True
    End Sub

    when I run the form and touch the button, I get the message box to display
    but the code does not stop, I put a breakpoint on the DoCmd line and it does
    not stop...
    "Ofer" wrote:

    > What happen, does the form still running, or does the code stop but you can't
    > see the actual code break?
    >
    > You can try and put
    > stop
    > To break the code in a certain line, instead of a code break.
    > Just don't forget to remove it when you finish
    > --
    > If I answered your question, please mark it as an answer. That way, it will
    > stay saved for a longer time, so other can benifit from it.
    >
    > Good luck
    >
    >
    >
    > "PeterM" wrote:
    >
    > > I have a .mdb that I created in Access 2003 using 2002 database format on
    > > another machine. I've now got to edit the database using Access 2002 on my
    > > current machine.
    > >
    > > The problem is that I can't run debug mode. Whenever I place a breakpoint
    > > on a line of code and open the form, the Visual Basic window does not open
    > > and show the breakpoint so I can step through the remaining code.
    > >
    > > Am I missing a setting somewhere, I've been thru References, Options, etc.
    > > everywhere i can think of...please help!
     
  4. George Nicholson

    George Nicholson
    Expand Collapse
    Guest

    In the Access interface (not the VBE): Tools>Startup>Uncheck "Use Access
    Special Keys"

    I've seen other posts that say having this checked can prevent breakpoints
    from breaking. I guess the theory is that Access considers a breakpoint as
    a pre-arranged Ctrl+Break, and if you've told it to ignore Ctrl+Brk, it'll
    ignore breakpoints too.

    HTH,
    --
    George Nicholson

    Remove 'Junk' from return address.


    "PeterM" <PeterM@discussions.microsoft.com> wrote in message
    news:A1939C1F-55E9-482C-BA33-887A9DCF85B2@microsoft.com...
    > The code does not stop....I have the following code assigned to a button
    >
    > Private Sub Command441_Click()
    > Stop
    > MsgBox "kdkdk"
    > DoCmd.SetWarnings False
    > Dim stDocName As String
    > Dim stLinkCriteria As String
    > stDocName = "broswer_display"
    > DoCmd.OpenForm stDocName, , , stLinkCriteria
    > DoCmd.SetWarnings True
    > End Sub
    >
    > when I run the form and touch the button, I get the message box to display
    > but the code does not stop, I put a breakpoint on the DoCmd line and it
    > does
    > not stop...
    > "Ofer" wrote:
    >
    >> What happen, does the form still running, or does the code stop but you
    >> can't
    >> see the actual code break?
    >>
    >> You can try and put
    >> stop
    >> To break the code in a certain line, instead of a code break.
    >> Just don't forget to remove it when you finish
    >> --
    >> If I answered your question, please mark it as an answer. That way, it
    >> will
    >> stay saved for a longer time, so other can benifit from it.
    >>
    >> Good luck
    >>
    >>
    >>
    >> "PeterM" wrote:
    >>
    >> > I have a .mdb that I created in Access 2003 using 2002 database format
    >> > on
    >> > another machine. I've now got to edit the database using Access 2002
    >> > on my
    >> > current machine.
    >> >
    >> > The problem is that I can't run debug mode. Whenever I place a
    >> > breakpoint
    >> > on a line of code and open the form, the Visual Basic window does not
    >> > open
    >> > and show the breakpoint so I can step through the remaining code.
    >> >
    >> > Am I missing a setting somewhere, I've been thru References, Options,
    >> > etc.
    >> > everywhere i can think of...please help!
     
  5. Dirk Goldgar

    Dirk Goldgar
    Expand Collapse
    Guest

    "George Nicholson" <JunkGeorgeN@msn.com> wrote in message
    news:e6Hmt2w2FHA.3912@TK2MSFTNGP15.phx.gbl
    > In the Access interface (not the VBE): Tools>Startup>Uncheck "Use
    > Access Special Keys"
    >
    > I've seen other posts that say having this checked can prevent
    > breakpoints from breaking. I guess the theory is that Access
    > considers a breakpoint as a pre-arranged Ctrl+Break, and if you've
    > told it to ignore Ctrl+Brk, it'll ignore breakpoints too.


    It's the other way around: if you want breakpoints to work, the "Use
    Access Special Keys" option must be checked.

    --
    Dirk Goldgar, MS Access MVP
    www.datagnostics.com

    (please reply to the newsgroup)
     
  6. George Nicholson

    George Nicholson
    Expand Collapse
    Guest

    I mispoke. Of course I had it backwards. Having it unchecked causes the
    behaviour the OP described.

    --
    George Nicholson

    Remove 'Junk' from return address.


    "Dirk Goldgar" <dg@NOdataSPAMgnostics.com> wrote in message
    news:uKogTWx2FHA.3732@TK2MSFTNGP15.phx.gbl...
    > "George Nicholson" <JunkGeorgeN@msn.com> wrote in message
    > news:e6Hmt2w2FHA.3912@TK2MSFTNGP15.phx.gbl
    >> In the Access interface (not the VBE): Tools>Startup>Uncheck "Use
    >> Access Special Keys"
    >>
    >> I've seen other posts that say having this checked can prevent
    >> breakpoints from breaking. I guess the theory is that Access
    >> considers a breakpoint as a pre-arranged Ctrl+Break, and if you've
    >> told it to ignore Ctrl+Brk, it'll ignore breakpoints too.

    >
    > It's the other way around: if you want breakpoints to work, the "Use
    > Access Special Keys" option must be checked.
    >
    > --
    > Dirk Goldgar, MS Access MVP
    > www.datagnostics.com
    >
    > (please reply to the newsgroup)
    >
    >
     
  7. PeterM

    PeterM
    Expand Collapse
    Guest

    thanks for responding....

    I verified that the Use Access Speckial keys is unchecked and it's still not
    stopping on breakpoints...is there another setting I'm missing?

    "George Nicholson" wrote:

    > In the Access interface (not the VBE): Tools>Startup>Uncheck "Use Access
    > Special Keys"
    >
    > I've seen other posts that say having this checked can prevent breakpoints
    > from breaking. I guess the theory is that Access considers a breakpoint as
    > a pre-arranged Ctrl+Break, and if you've told it to ignore Ctrl+Brk, it'll
    > ignore breakpoints too.
    >
    > HTH,
    > --
    > George Nicholson
    >
    > Remove 'Junk' from return address.
    >
    >
    > "PeterM" <PeterM@discussions.microsoft.com> wrote in message
    > news:A1939C1F-55E9-482C-BA33-887A9DCF85B2@microsoft.com...
    > > The code does not stop....I have the following code assigned to a button
    > >
    > > Private Sub Command441_Click()
    > > Stop
    > > MsgBox "kdkdk"
    > > DoCmd.SetWarnings False
    > > Dim stDocName As String
    > > Dim stLinkCriteria As String
    > > stDocName = "broswer_display"
    > > DoCmd.OpenForm stDocName, , , stLinkCriteria
    > > DoCmd.SetWarnings True
    > > End Sub
    > >
    > > when I run the form and touch the button, I get the message box to display
    > > but the code does not stop, I put a breakpoint on the DoCmd line and it
    > > does
    > > not stop...
    > > "Ofer" wrote:
    > >
    > >> What happen, does the form still running, or does the code stop but you
    > >> can't
    > >> see the actual code break?
    > >>
    > >> You can try and put
    > >> stop
    > >> To break the code in a certain line, instead of a code break.
    > >> Just don't forget to remove it when you finish
    > >> --
    > >> If I answered your question, please mark it as an answer. That way, it
    > >> will
    > >> stay saved for a longer time, so other can benifit from it.
    > >>
    > >> Good luck
    > >>
    > >>
    > >>
    > >> "PeterM" wrote:
    > >>
    > >> > I have a .mdb that I created in Access 2003 using 2002 database format
    > >> > on
    > >> > another machine. I've now got to edit the database using Access 2002
    > >> > on my
    > >> > current machine.
    > >> >
    > >> > The problem is that I can't run debug mode. Whenever I place a
    > >> > breakpoint
    > >> > on a line of code and open the form, the Visual Basic window does not
    > >> > open
    > >> > and show the breakpoint so I can step through the remaining code.
    > >> >
    > >> > Am I missing a setting somewhere, I've been thru References, Options,
    > >> > etc.
    > >> > everywhere i can think of...please help!

    >
    >
    >
     
  8. Dirk Goldgar

    Dirk Goldgar
    Expand Collapse
    Guest

    "PeterM" <PeterM@discussions.microsoft.com> wrote in message
    news:5C5FDA16-4B03-450D-940C-C2CC2E673037@microsoft.com
    > thanks for responding....
    >
    > I verified that the Use Access Speckial keys is unchecked and it's
    > still not stopping on breakpoints...is there another setting I'm
    > missing?


    "Use Access Special Keys" must be checked, not unchecked.

    --
    Dirk Goldgar, MS Access MVP
    www.datagnostics.com

    (please reply to the newsgroup)
     
  9. PeterM

    PeterM
    Expand Collapse
    Guest

    I just turned the Access Special Keys on and it's still not stopping at
    breakpoints...any other ideas?

    "Dirk Goldgar" wrote:

    > "George Nicholson" <JunkGeorgeN@msn.com> wrote in message
    > news:e6Hmt2w2FHA.3912@TK2MSFTNGP15.phx.gbl
    > > In the Access interface (not the VBE): Tools>Startup>Uncheck "Use
    > > Access Special Keys"
    > >
    > > I've seen other posts that say having this checked can prevent
    > > breakpoints from breaking. I guess the theory is that Access
    > > considers a breakpoint as a pre-arranged Ctrl+Break, and if you've
    > > told it to ignore Ctrl+Brk, it'll ignore breakpoints too.

    >
    > It's the other way around: if you want breakpoints to work, the "Use
    > Access Special Keys" option must be checked.
    >
    > --
    > Dirk Goldgar, MS Access MVP
    > www.datagnostics.com
    >
    > (please reply to the newsgroup)
    >
    >
    >
     
  10. PeterM

    PeterM
    Expand Collapse
    Guest

    I added

    Msgbox "Open" in the form_open procedure and it displays the msgbox when it
    opens, I then put a breakpoint on the msgbox statement and it still does not
    recognize it as a breakpoint...I did turn Access Special keys on...this is
    driving me nuts!

    "George Nicholson" wrote:

    > I mispoke. Of course I had it backwards. Having it unchecked causes the
    > behaviour the OP described.
    >
    > --
    > George Nicholson
    >
    > Remove 'Junk' from return address.
    >
    >
    > "Dirk Goldgar" <dg@NOdataSPAMgnostics.com> wrote in message
    > news:uKogTWx2FHA.3732@TK2MSFTNGP15.phx.gbl...
    > > "George Nicholson" <JunkGeorgeN@msn.com> wrote in message
    > > news:e6Hmt2w2FHA.3912@TK2MSFTNGP15.phx.gbl
    > >> In the Access interface (not the VBE): Tools>Startup>Uncheck "Use
    > >> Access Special Keys"
    > >>
    > >> I've seen other posts that say having this checked can prevent
    > >> breakpoints from breaking. I guess the theory is that Access
    > >> considers a breakpoint as a pre-arranged Ctrl+Break, and if you've
    > >> told it to ignore Ctrl+Brk, it'll ignore breakpoints too.

    > >
    > > It's the other way around: if you want breakpoints to work, the "Use
    > > Access Special Keys" option must be checked.
    > >
    > > --
    > > Dirk Goldgar, MS Access MVP
    > > www.datagnostics.com
    > >
    > > (please reply to the newsgroup)
    > >
    > >

    >
    >
    >
     
  11. PeterM

    PeterM
    Expand Collapse
    Guest

    sorry...I wrote this before seeing the other messages, it is turned on now
    and still does not work.........

    "Dirk Goldgar" wrote:

    > "PeterM" <PeterM@discussions.microsoft.com> wrote in message
    > news:5C5FDA16-4B03-450D-940C-C2CC2E673037@microsoft.com
    > > thanks for responding....
    > >
    > > I verified that the Use Access Speckial keys is unchecked and it's
    > > still not stopping on breakpoints...is there another setting I'm
    > > missing?

    >
    > "Use Access Special Keys" must be checked, not unchecked.
    >
    > --
    > Dirk Goldgar, MS Access MVP
    > www.datagnostics.com
    >
    > (please reply to the newsgroup)
    >
    >
    >
     
  12. Dirk Goldgar

    Dirk Goldgar
    Expand Collapse
    Guest

    "PeterM" <PeterM@discussions.microsoft.com> wrote in message
    news:C14186AB-464B-4D5B-A99B-67F6FC96AAEC@microsoft.com
    > I just turned the Access Special Keys on and it's still not stopping
    > at breakpoints...any other ideas?


    Since you say you created this database on a different PC, maybe there's
    a broken refernce causing your problem. See if the steps outlined here
    help:

    http://www.accessmvp.com/djsteele/AccessReferenceErrors.html

    --
    Dirk Goldgar, MS Access MVP
    www.datagnostics.com

    (please reply to the newsgroup)
     

Share This Page