Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

Could not open table 'MSysAccounts' in the workgroup information f

Discussion in 'Information Technology' started by Shawn, Jul 28, 2006.

  1. Shawn

    Shawn
    Expand Collapse
    Guest

    I get this message when I try to open a new database. If I click help I get
    this message :

    "Could not open table 'MSysAccounts' in the workgroup information file.
    (Error 3173)
    This operation requires the System.mdw file, which contains the security and
    option settings for Microsoft Jet database tables.

    Possible causes:

    The SystemDB value of the
    \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet
    key in the Microsoft® Windows® Registry points to a network drive that is not
    connected. Make sure the network drive is available, and then try the
    operation again.
    The System.mdw file is corrupted. If you have a backup copy of System.mdw,
    copy it to the location specified in the SystemDB entry in the Registry. "

    When I search my harddrive I can't find the "system.mdw" file anywhere. I
    currently have a database that I can use, but I can't open any other
    database, nor create a new one.
     
  2. Loading...


  3. Joan Wild

    Joan Wild
    Expand Collapse
    Guest

    When you searched your harddrive, did you ensure you were searching hidden
    and system folders?

    You may be able to copy system.mdw from another computer that has 2000
    installed.

    Regarding the database you can use, is it secured? What mdw file is it
    using if not system.mdw?

    Was the problem database originally in version 2.0 and converted?

    --
    Joan Wild
    Microsoft Access MVP

    Shawn wrote:
    > I get this message when I try to open a new database. If I click
    > help I get this message :
    >
    > "Could not open table 'MSysAccounts' in the workgroup information
    > file. (Error 3173)
    > This operation requires the System.mdw file, which contains the
    > security and option settings for Microsoft Jet database tables.
    >
    > Possible causes:
    >
    > The SystemDB value of the
    > \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet
    > key in the Microsoft® Windows® Registry points to a network drive
    > that is not connected. Make sure the network drive is available, and
    > then try the operation again.
    > The System.mdw file is corrupted. If you have a backup copy of
    > System.mdw, copy it to the location specified in the SystemDB entry
    > in the Registry. "
    >
    > When I search my harddrive I can't find the "system.mdw" file
    > anywhere. I currently have a database that I can use, but I can't
    > open any other database, nor create a new one.
     
  4. Shawn

    Shawn
    Expand Collapse
    Guest

    Re: Could not open table 'MSysAccounts' in the workgroup informati

    Thank you. I found the file (it was a hidden file). If I copy this file
    then where should I paste it?

    Concerning my current database. I created it in January and have finagled
    my way through until today. I believe that this problem started when I got
    into the security section and tried to turn off all security. I don't want
    any security on this. I would like to back it up on a zip drive and run it
    on any PC w/ Access.

    Something interesting: I can only run the database from the shortcut. I
    can't run it from the original file because I get the same error code. If I
    create another shortcut it still gives me the error code. I copied the
    target from the shortcut and here is the results:

    working target (from original shortcut):

    "C:\Program Files\Microsoft Office\OFFICE11\MSACCESS.EXE" "C:\Documents and
    Settings\Shawn Knapp.BENNETT-INDIANA\My Documents\Call Logs\Call Logs
    2003.mdb" /WRKGRP "C:\Documents and Settings\Shawn Knapp.BENNETT-INDIANA\My
    Documents\Call Logs\Security.mdw"

    non-working target (from a new created shortcut) :

    "C:\Documents and Settings\Shawn Knapp.BENNETT-INDIANA\My Documents\Call
    Logs\Call Logs 2003.mdb"

    If I copy and paste the target from the working shortcut into the
    non-working shortcut then it will work.

    The database was originally created from Office 96 (I think). I converted
    it to 2003. I can't be sure if this was when the problem started.

    Thank you for your time.

    "Joan Wild" wrote:

    > When you searched your harddrive, did you ensure you were searching hidden
    > and system folders?
    >
    > You may be able to copy system.mdw from another computer that has 2000
    > installed.
    >
    > Regarding the database you can use, is it secured? What mdw file is it
    > using if not system.mdw?
    >
    > Was the problem database originally in version 2.0 and converted?
    >
    > --
    > Joan Wild
    > Microsoft Access MVP
    >
    > Shawn wrote:
    > > I get this message when I try to open a new database. If I click
    > > help I get this message :
    > >
    > > "Could not open table 'MSysAccounts' in the workgroup information
    > > file. (Error 3173)
    > > This operation requires the System.mdw file, which contains the
    > > security and option settings for Microsoft Jet database tables.
    > >
    > > Possible causes:
    > >
    > > The SystemDB value of the
    > > \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet
    > > key in the Microsoft® Windows® Registry points to a network drive
    > > that is not connected. Make sure the network drive is available, and
    > > then try the operation again.
    > > The System.mdw file is corrupted. If you have a backup copy of
    > > System.mdw, copy it to the location specified in the SystemDB entry
    > > in the Registry. "
    > >
    > > When I search my harddrive I can't find the "system.mdw" file
    > > anywhere. I currently have a database that I can use, but I can't
    > > open any other database, nor create a new one.

    >
    >
    >
     
  5. Joan Wild

    Joan Wild
    Expand Collapse
    Guest

    Re: Could not open table 'MSysAccounts' in the workgroup informati

    Shawn wrote:
    > Thank you. I found the file (it was a hidden file). If I copy this
    > file then where should I paste it?


    No, since you found it on your computer, no need to copy it anywhere.

    Use Start, Run, wrkgadm.exe and make sure you are currently joined to this
    system.mdw (double check the path). This will make the system.mdw the
    default, which is what you want.

    > Concerning my current database. I created it in January and have
    > finagled my way through until today. I believe that this problem
    > started when I got into the security section and tried to turn off
    > all security. I don't want any security on this. I would like to
    > back it up on a zip drive and run it on any PC w/ Access.


    Understand that Access always uses security. It uses system.mdw out of the
    box, and silently logs you in as the Admin user. Every installation of
    Access uses this. When you implement security, you create a new mdw file,
    and use this one for the secured mdb.

    > Something interesting: I can only run the database from the
    > shortcut. I can't run it from the original file because I get the
    > same error code.


    Yes this makes sense. The shortcut that is working, utilizes the /wrkgrp
    switch to tell Access to use your secure.mdw for that session of Access.
    Since your mdb is secured, and you are using the correct mdw, you get in.

    When you try to open the file directly, it uses your default system.mdw.
    You are silently logged in as Admin, and Admin doesn't have any permissions
    in your secure mdb (and rightly so).

    > If I create another shortcut it still gives me the
    > error code. I copied the target from the shortcut and here is the
    > results:
    >
    > working target (from original shortcut):
    >
    > "C:\Program Files\Microsoft Office\OFFICE11\MSACCESS.EXE"
    > "C:\Documents and Settings\Shawn Knapp.BENNETT-INDIANA\My
    > Documents\Call Logs\Call Logs 2003.mdb" /WRKGRP "C:\Documents and
    > Settings\Shawn Knapp.BENNETT-INDIANA\My Documents\Call
    > Logs\Security.mdw"


    The /wrkgrp switch tells access to use security.mdw, and you can login.

    > non-working target (from a new created shortcut) :
    >
    > "C:\Documents and Settings\Shawn Knapp.BENNETT-INDIANA\My
    > Documents\Call Logs\Call Logs 2003.mdb"


    This one will use your default mdw, which in the workgroup administrator is
    set to system.mdw - That workgroup doesn't contain an authenticated user so
    it fails.

    This is working as it should. It just appears that it can't find the
    system.mdw.

    Try Start, Run, wrkgadm.exe Click on Join and navigate to the location of
    system.mdw that you found in your search in the hidden folder.

    Can you now open Access and create a new mdb?

    If not, then try copying system.mdw from the hidden folder to c:\Program
    Files\Common Files\System folder (that's where mine is). Rerun wrkgadm.exe
    and join it in this location.

    If that is still a problem, then copy it to c:\Documents and
    Settings\username\Application Data\Microsoft\Access folder and again Join it
    in this location.

    >
    > The database was originally created from Office 96 (I think). I
    > converted it to 2003. I can't be sure if this was when the problem
    > started.


    Probably Office 97.

    If you still want to remove all security, use the desktop shortcut to login
    to your secure mdb. Grant full permissions to all objects for the Users
    Group. Close Access. Now reopen Access (not using the shortcut). Create a
    new mdb and import all objects from your secure mdb. This new mdb will be
    unsecured and you are safe to delete secure.mdw and your old secure mdb.

    --
    Joan Wild
    Microsoft Access MVP
     
  6. Shawn

    Shawn
    Expand Collapse
    Guest

    Re: Could not open table 'MSysAccounts' in the workgroup informati

    Joan,
    Wow, I'm really getting somewhere. Thank you. I try running "wrkgadm.exe"
    from my Start / Run Menu (XP) but I don't think that I have the file. I
    searched for it and it's no where to be found. Where can I get the file?
    Thanks

    "Joan Wild" wrote:

    >
    > Shawn wrote:
    > > Thank you. I found the file (it was a hidden file). If I copy this
    > > file then where should I paste it?

    >
    > No, since you found it on your computer, no need to copy it anywhere.
    >
    > Use Start, Run, wrkgadm.exe and make sure you are currently joined to this
    > system.mdw (double check the path). This will make the system.mdw the
    > default, which is what you want.
    >
    > > Concerning my current database. I created it in January and have
    > > finagled my way through until today. I believe that this problem
    > > started when I got into the security section and tried to turn off
    > > all security. I don't want any security on this. I would like to
    > > back it up on a zip drive and run it on any PC w/ Access.

    >
    > Understand that Access always uses security. It uses system.mdw out of the
    > box, and silently logs you in as the Admin user. Every installation of
    > Access uses this. When you implement security, you create a new mdw file,
    > and use this one for the secured mdb.
    >
    > > Something interesting: I can only run the database from the
    > > shortcut. I can't run it from the original file because I get the
    > > same error code.

    >
    > Yes this makes sense. The shortcut that is working, utilizes the /wrkgrp
    > switch to tell Access to use your secure.mdw for that session of Access.
    > Since your mdb is secured, and you are using the correct mdw, you get in.
    >
    > When you try to open the file directly, it uses your default system.mdw.
    > You are silently logged in as Admin, and Admin doesn't have any permissions
    > in your secure mdb (and rightly so).
    >
    > > If I create another shortcut it still gives me the
    > > error code. I copied the target from the shortcut and here is the
    > > results:
    > >
    > > working target (from original shortcut):
    > >
    > > "C:\Program Files\Microsoft Office\OFFICE11\MSACCESS.EXE"
    > > "C:\Documents and Settings\Shawn Knapp.BENNETT-INDIANA\My
    > > Documents\Call Logs\Call Logs 2003.mdb" /WRKGRP "C:\Documents and
    > > Settings\Shawn Knapp.BENNETT-INDIANA\My Documents\Call
    > > Logs\Security.mdw"

    >
    > The /wrkgrp switch tells access to use security.mdw, and you can login.
    >
    > > non-working target (from a new created shortcut) :
    > >
    > > "C:\Documents and Settings\Shawn Knapp.BENNETT-INDIANA\My
    > > Documents\Call Logs\Call Logs 2003.mdb"

    >
    > This one will use your default mdw, which in the workgroup administrator is
    > set to system.mdw - That workgroup doesn't contain an authenticated user so
    > it fails.
    >
    > This is working as it should. It just appears that it can't find the
    > system.mdw.
    >
    > Try Start, Run, wrkgadm.exe Click on Join and navigate to the location of
    > system.mdw that you found in your search in the hidden folder.
    >
    > Can you now open Access and create a new mdb?
    >
    > If not, then try copying system.mdw from the hidden folder to c:\Program
    > Files\Common Files\System folder (that's where mine is). Rerun wrkgadm.exe
    > and join it in this location.
    >
    > If that is still a problem, then copy it to c:\Documents and
    > Settings\username\Application Data\Microsoft\Access folder and again Join it
    > in this location.
    >
    > >
    > > The database was originally created from Office 96 (I think). I
    > > converted it to 2003. I can't be sure if this was when the problem
    > > started.

    >
    > Probably Office 97.
    >
    > If you still want to remove all security, use the desktop shortcut to login
    > to your secure mdb. Grant full permissions to all objects for the Users
    > Group. Close Access. Now reopen Access (not using the shortcut). Create a
    > new mdb and import all objects from your secure mdb. This new mdb will be
    > unsecured and you are safe to delete secure.mdw and your old secure mdb.
    >
    > --
    > Joan Wild
    > Microsoft Access MVP
    >
    >
    >
     
  7. Joan Wild

    Joan Wild
    Expand Collapse
    Guest

    Re: Could not open table 'MSysAccounts' in the workgroup informati

    My apologies; somewhere I got the impression you were using version 2000.

    In 2003, there is no separate wrkgadm.exe - it's now built into Access.
    Open Access and go to Tools, Security, Workgroup Administrator.


    --
    Joan Wild
    Microsoft Access MVP

    Shawn wrote:
    > Joan,
    > Wow, I'm really getting somewhere. Thank you. I try running
    > "wrkgadm.exe" from my Start / Run Menu (XP) but I don't think that I
    > have the file. I searched for it and it's no where to be found.
    > Where can I get the file? Thanks
    >
    > "Joan Wild" wrote:
    >
    >>
    >> Shawn wrote:
    >>> Thank you. I found the file (it was a hidden file). If I copy this
    >>> file then where should I paste it?

    >>
    >> No, since you found it on your computer, no need to copy it anywhere.
    >>
    >> Use Start, Run, wrkgadm.exe and make sure you are currently joined
    >> to this system.mdw (double check the path). This will make the
    >> system.mdw the default, which is what you want.
    >>
    >>> Concerning my current database. I created it in January and have
    >>> finagled my way through until today. I believe that this problem
    >>> started when I got into the security section and tried to turn off
    >>> all security. I don't want any security on this. I would like to
    >>> back it up on a zip drive and run it on any PC w/ Access.

    >>
    >> Understand that Access always uses security. It uses system.mdw out
    >> of the box, and silently logs you in as the Admin user. Every
    >> installation of Access uses this. When you implement security, you
    >> create a new mdw file, and use this one for the secured mdb.
    >>
    >>> Something interesting: I can only run the database from the
    >>> shortcut. I can't run it from the original file because I get the
    >>> same error code.

    >>
    >> Yes this makes sense. The shortcut that is working, utilizes the
    >> /wrkgrp switch to tell Access to use your secure.mdw for that
    >> session of Access. Since your mdb is secured, and you are using the
    >> correct mdw, you get in.
    >>
    >> When you try to open the file directly, it uses your default
    >> system.mdw. You are silently logged in as Admin, and Admin doesn't
    >> have any permissions in your secure mdb (and rightly so).
    >>
    >>> If I create another shortcut it still gives me the
    >>> error code. I copied the target from the shortcut and here is the
    >>> results:
    >>>
    >>> working target (from original shortcut):
    >>>
    >>> "C:\Program Files\Microsoft Office\OFFICE11\MSACCESS.EXE"
    >>> "C:\Documents and Settings\Shawn Knapp.BENNETT-INDIANA\My
    >>> Documents\Call Logs\Call Logs 2003.mdb" /WRKGRP "C:\Documents and
    >>> Settings\Shawn Knapp.BENNETT-INDIANA\My Documents\Call
    >>> Logs\Security.mdw"

    >>
    >> The /wrkgrp switch tells access to use security.mdw, and you can
    >> login.
    >>
    >>> non-working target (from a new created shortcut) :
    >>>
    >>> "C:\Documents and Settings\Shawn Knapp.BENNETT-INDIANA\My
    >>> Documents\Call Logs\Call Logs 2003.mdb"

    >>
    >> This one will use your default mdw, which in the workgroup
    >> administrator is set to system.mdw - That workgroup doesn't contain
    >> an authenticated user so it fails.
    >>
    >> This is working as it should. It just appears that it can't find the
    >> system.mdw.
    >>
    >> Try Start, Run, wrkgadm.exe Click on Join and navigate to the
    >> location of system.mdw that you found in your search in the hidden
    >> folder.
    >>
    >> Can you now open Access and create a new mdb?
    >>
    >> If not, then try copying system.mdw from the hidden folder to
    >> c:\Program Files\Common Files\System folder (that's where mine is).
    >> Rerun wrkgadm.exe and join it in this location.
    >>
    >> If that is still a problem, then copy it to c:\Documents and
    >> Settings\username\Application Data\Microsoft\Access folder and again
    >> Join it in this location.
    >>
    >>>
    >>> The database was originally created from Office 96 (I think). I
    >>> converted it to 2003. I can't be sure if this was when the problem
    >>> started.

    >>
    >> Probably Office 97.
    >>
    >> If you still want to remove all security, use the desktop shortcut
    >> to login to your secure mdb. Grant full permissions to all objects
    >> for the Users Group. Close Access. Now reopen Access (not using
    >> the shortcut). Create a new mdb and import all objects from your
    >> secure mdb. This new mdb will be unsecured and you are safe to
    >> delete secure.mdw and your old secure mdb.
    >>
    >> --
    >> Joan Wild
    >> Microsoft Access MVP
     

Share This Page