Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

Can't use Find function in subform

Discussion in 'Information Technology' started by Chris Burnette, Nov 18, 2005.

  1. Chris Burnette

    Chris Burnette
    Expand Collapse

    I currently have a form based on 4 tables. The main form is based on 1
    table, and I have a tab control with 3 subforms, each in their own tab. I am
    using the LinkMaster/LinkChild fields property to make sure that the IDs in
    all the forms match up, but that records are created in a particular table
    only if data is entered in the corresponding subform.

    While this all seems to work perfectly well, the major problem I am having
    now is that when I use the LinkMaster/LinkChild fields, I am no longer able
    to use the Find function to search for records in my subforms, as there is
    usually only 1 record that is linked.

    If I don't use LinkMaster/LinkChild fields, I am not sure how to make sure
    that the records in my tables are all properly linked (i.e. all have the same
    FK relationship). In addition, when I scroll through my main form it doesn't
    move to the corresponding record in my subform, and vice versa.

    So, my question is whether or not there is a way to use the Find function in
    a subform, and if not, then how should I change my form so that I can keep
    the records in the tables linked?

    I am a bit stumped on this one, so as always any help would be appreciated.


  2. Loading...

Share This Page