Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

Autonumbering

Discussion in 'Information Technology' started by dgustin, Nov 16, 2005.

  1. dgustin

    dgustin
    Expand Collapse
    Guest

    I was working on a database and it was autonumbering just fine. when i went
    to open it up the autonumbering was disabled. how do i turn that fuction
    back on??
    I have tried changing the data field from number to autonumber and i get a
    error message that reads:

    Once you entered data in a table, you can not change the datat type of any
    field to autonumber even if you haven't yet added data to that field.

    Add a new field to the table, and define its data type as autonumber
    Microsoft office access then enters data in the autonumber field
    automatically, numbering the recordsconsecutively starting with 1.
     
  2. Douglas J Steele

    Douglas J Steele
    Expand Collapse
    Guest

    What do you mean by "disabled"? Are you saying numbers were no longer being
    generated?

    --
    Doug Steele, Microsoft Access MVP
    http://I.Am/DougSteele
    (no e-mails, please!)


    "dgustin" <dgustin@discussions.microsoft.com> wrote in message
    news:81EA38A1-708B-4EC0-B323-2BED80D21F61@microsoft.com...
    > I was working on a database and it was autonumbering just fine. when i

    went
    > to open it up the autonumbering was disabled. how do i turn that fuction
    > back on??
    > I have tried changing the data field from number to autonumber and i get a
    > error message that reads:
    >
    > Once you entered data in a table, you can not change the datat type of any
    > field to autonumber even if you haven't yet added data to that field.
    >
    > Add a new field to the table, and define its data type as autonumber
    > Microsoft office access then enters data in the autonumber field
    > automatically, numbering the recordsconsecutively starting with 1.
     
  3. dgustin

    dgustin
    Expand Collapse
    Guest

    nope, i have to go in manually and insert the numbers

    "Douglas J Steele" wrote:

    > What do you mean by "disabled"? Are you saying numbers were no longer being
    > generated?
    >
    > --
    > Doug Steele, Microsoft Access MVP
    > http://I.Am/DougSteele
    > (no e-mails, please!)
    >
    >
    > "dgustin" <dgustin@discussions.microsoft.com> wrote in message
    > news:81EA38A1-708B-4EC0-B323-2BED80D21F61@microsoft.com...
    > > I was working on a database and it was autonumbering just fine. when i

    > went
    > > to open it up the autonumbering was disabled. how do i turn that fuction
    > > back on??
    > > I have tried changing the data field from number to autonumber and i get a
    > > error message that reads:
    > >
    > > Once you entered data in a table, you can not change the datat type of any
    > > field to autonumber even if you haven't yet added data to that field.
    > >
    > > Add a new field to the table, and define its data type as autonumber
    > > Microsoft office access then enters data in the autonumber field
    > > automatically, numbering the recordsconsecutively starting with 1.

    >
    >
    >
     
  4. Douglas J Steele

    Douglas J Steele
    Expand Collapse
    Guest

    I've never heard of this before!

    So you're inserting values into other fields in the table, the new record's
    getting saved, but the Autonumber field isn't getting a value in it?

    --
    Doug Steele, Microsoft Access MVP
    http://I.Am/DougSteele
    (no e-mails, please!)


    "dgustin" <dgustin@discussions.microsoft.com> wrote in message
    news:C449927D-496E-4390-8507-EA621B7E6C67@microsoft.com...
    > nope, i have to go in manually and insert the numbers
    >
    > "Douglas J Steele" wrote:
    >
    > > What do you mean by "disabled"? Are you saying numbers were no longer

    being
    > > generated?
    > >
    > > --
    > > Doug Steele, Microsoft Access MVP
    > > http://I.Am/DougSteele
    > > (no e-mails, please!)
    > >
    > >
    > > "dgustin" <dgustin@discussions.microsoft.com> wrote in message
    > > news:81EA38A1-708B-4EC0-B323-2BED80D21F61@microsoft.com...
    > > > I was working on a database and it was autonumbering just fine. when

    i
    > > went
    > > > to open it up the autonumbering was disabled. how do i turn that

    fuction
    > > > back on??
    > > > I have tried changing the data field from number to autonumber and i

    get a
    > > > error message that reads:
    > > >
    > > > Once you entered data in a table, you can not change the datat type of

    any
    > > > field to autonumber even if you haven't yet added data to that field.
    > > >
    > > > Add a new field to the table, and define its data type as autonumber
    > > > Microsoft office access then enters data in the autonumber field
    > > > automatically, numbering the recordsconsecutively starting with 1.

    > >
    > >
    > >
     
  5. dgustin

    dgustin
    Expand Collapse
    Guest

    it saves the record but it doesn't input a autonumber


    "Douglas J Steele" wrote:

    > I've never heard of this before!
    >
    > So you're inserting values into other fields in the table, the new record's
    > getting saved, but the Autonumber field isn't getting a value in it?
    >
    > --
    > Doug Steele, Microsoft Access MVP
    > http://I.Am/DougSteele
    > (no e-mails, please!)
    >
    >
    > "dgustin" <dgustin@discussions.microsoft.com> wrote in message
    > news:C449927D-496E-4390-8507-EA621B7E6C67@microsoft.com...
    > > nope, i have to go in manually and insert the numbers
    > >
    > > "Douglas J Steele" wrote:
    > >
    > > > What do you mean by "disabled"? Are you saying numbers were no longer

    > being
    > > > generated?
    > > >
    > > > --
    > > > Doug Steele, Microsoft Access MVP
    > > > http://I.Am/DougSteele
    > > > (no e-mails, please!)
    > > >
    > > >
    > > > "dgustin" <dgustin@discussions.microsoft.com> wrote in message
    > > > news:81EA38A1-708B-4EC0-B323-2BED80D21F61@microsoft.com...
    > > > > I was working on a database and it was autonumbering just fine. when

    > i
    > > > went
    > > > > to open it up the autonumbering was disabled. how do i turn that

    > fuction
    > > > > back on??
    > > > > I have tried changing the data field from number to autonumber and i

    > get a
    > > > > error message that reads:
    > > > >
    > > > > Once you entered data in a table, you can not change the datat type of

    > any
    > > > > field to autonumber even if you haven't yet added data to that field.
    > > > >
    > > > > Add a new field to the table, and define its data type as autonumber
    > > > > Microsoft office access then enters data in the autonumber field
    > > > > automatically, numbering the recordsconsecutively starting with 1.
    > > >
    > > >
    > > >

    >
    >
    >
     
  6. Ken Snell [MVP]

    Ken Snell [MVP]
    Expand Collapse
    Guest

    How many fields in the table have Autonumber as the data type? Which field
    or fields is/are the primary key for the table? Provide the full details
    about this table's structure: names of fields, data type of each field,
    field size of each field.

    And to confirm, if you enter data into the table, this autonumber field
    isn't automatically assigned a value -- you're not talking about entering
    data via a form, right?

    --

    Ken Snell
    <MS ACCESS MVP>



    "dgustin" <dgustin@discussions.microsoft.com> wrote in message
    news:E74C8947-DC30-4668-9EFE-C6205C5CF35D@microsoft.com...
    > it saves the record but it doesn't input a autonumber
    >
    >
    > "Douglas J Steele" wrote:
    >
    >> I've never heard of this before!
    >>
    >> So you're inserting values into other fields in the table, the new
    >> record's
    >> getting saved, but the Autonumber field isn't getting a value in it?
    >>
    >> --
    >> Doug Steele, Microsoft Access MVP
    >> http://I.Am/DougSteele
    >> (no e-mails, please!)
    >>
    >>
    >> "dgustin" <dgustin@discussions.microsoft.com> wrote in message
    >> news:C449927D-496E-4390-8507-EA621B7E6C67@microsoft.com...
    >> > nope, i have to go in manually and insert the numbers
    >> >
    >> > "Douglas J Steele" wrote:
    >> >
    >> > > What do you mean by "disabled"? Are you saying numbers were no longer

    >> being
    >> > > generated?
    >> > >
    >> > > --
    >> > > Doug Steele, Microsoft Access MVP
    >> > > http://I.Am/DougSteele
    >> > > (no e-mails, please!)
    >> > >
    >> > >
    >> > > "dgustin" <dgustin@discussions.microsoft.com> wrote in message
    >> > > news:81EA38A1-708B-4EC0-B323-2BED80D21F61@microsoft.com...
    >> > > > I was working on a database and it was autonumbering just fine.
    >> > > > when

    >> i
    >> > > went
    >> > > > to open it up the autonumbering was disabled. how do i turn that

    >> fuction
    >> > > > back on??
    >> > > > I have tried changing the data field from number to autonumber and
    >> > > > i

    >> get a
    >> > > > error message that reads:
    >> > > >
    >> > > > Once you entered data in a table, you can not change the datat type
    >> > > > of

    >> any
    >> > > > field to autonumber even if you haven't yet added data to that
    >> > > > field.
    >> > > >
    >> > > > Add a new field to the table, and define its data type as
    >> > > > autonumber
    >> > > > Microsoft office access then enters data in the autonumber field
    >> > > > automatically, numbering the recordsconsecutively starting with 1.
    >> > >
    >> > >
    >> > >

    >>
    >>
    >>
     

Share This Page