Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

Any Way to Force Default Connection to SQLOLEDB Driver?

Discussion in 'Information Technology' started by Will, Jul 28, 2006.

  1. Will

    Will
    Expand Collapse
    Guest

    After upgrading machines to Windows 2003 SP1, we are noticing strange
    behavior of recordsets in Access 2003. There are many similar reports on
    the Internet, and it appears that these trace to the fact that the default
    connection in Access is not using the SQLOLEDB driver. Apparently the ODBC
    driver is not very stable, and the SQLOLEDB driver is what we want to be
    using. Is there a way to force Access to use SQLOLEDB for its *default*
    connection, or do we just have to use our own custom connection if we want
    to control driver selection?

    My programmer had the concern that even if we could force the default
    connection to use OLEDB that this might cause the bound forms to start
    behaving unpredictably.

    Any advice on how to get Access using SQLOLEDB across the board is
    appreciated.

    --
    Will
     
  2. Loading...

    Similar Threads Forum Date
    Ashdoc's Movie Review---Force 2 Theatre, Movies & Cinema Nov 20, 2016
    Interfaith Religious Freedom For Sikhs In The US Armed Forces Interfaith Dialogues Apr 20, 2016
    Hard Talk Toronto Youtube Star Jus Reign Was Forced To Remove His Turban At A California Airport Hard Talk Feb 24, 2016
    The force Blogs Oct 17, 2015
    How message of love from Sikh gurus are helping Pakistani Christians to fight forced conversions Sikh Sikhi Sikhism Oct 12, 2015

  3. Rick Brandt

    Rick Brandt
    Expand Collapse
    Guest

    Will wrote:
    > After upgrading machines to Windows 2003 SP1, we are noticing strange
    > behavior of recordsets in Access 2003. There are many similar
    > reports on the Internet, and it appears that these trace to the fact
    > that the default connection in Access is not using the SQLOLEDB
    > driver. Apparently the ODBC driver is not very stable, and the
    > SQLOLEDB driver is what we want to be using. Is there a way to
    > force Access to use SQLOLEDB for its *default* connection, or do we
    > just have to use our own custom connection if we want to control
    > driver selection?
    >
    > My programmer had the concern that even if we could force the default
    > connection to use OLEDB that this might cause the bound forms to start
    > behaving unpredictably.
    >
    > Any advice on how to get Access using SQLOLEDB across the board is
    > appreciated.


    You can't. And there is nothing "unstable" about the ODBC driver.

    --
    Rick Brandt, Microsoft Access MVP
    Email (as appropriate) to...
    RBrandt at Hunter dot com
     
  4. Norman Yuan

    Norman Yuan
    Expand Collapse
    Guest

    If your are talking Access front end connecting to SQL Server, you have two
    ways: with *.mdb, you connect via ODBC, no other option; with *.adp, you use
    SQL OLEDB, no other option, agian.

    "Will" <westes-usc@noemail.nospam> wrote in message
    news:OBd24PUsGHA.904@TK2MSFTNGP03.phx.gbl...
    > After upgrading machines to Windows 2003 SP1, we are noticing strange
    > behavior of recordsets in Access 2003. There are many similar reports
    > on
    > the Internet, and it appears that these trace to the fact that the default
    > connection in Access is not using the SQLOLEDB driver. Apparently the
    > ODBC
    > driver is not very stable, and the SQLOLEDB driver is what we want to be
    > using. Is there a way to force Access to use SQLOLEDB for its *default*
    > connection, or do we just have to use our own custom connection if we want
    > to control driver selection?
    >
    > My programmer had the concern that even if we could force the default
    > connection to use OLEDB that this might cause the bound forms to start
    > behaving unpredictably.
    >
    > Any advice on how to get Access using SQLOLEDB across the board is
    > appreciated.
    >
    > --
    > Will
    >
    >
     

Share This Page