Welcome to SPN

Register and Join the most happening forum of Sikh community & intellectuals from around the world.

Sign Up Now!

Access not creating .ldb intermitantlly

Discussion in 'Information Technology' started by charlief, Jul 28, 2006.

  1. charlief

    charlief
    Expand Collapse
    Guest

    Hi all.
    I am pulling my hair out, and would appriciate some help while i have some
    hair left.
    I have various Access DB for users to access on a server. When a user opens
    the DB there is a 60/40 change that it will not create a .ldb lock.
    I have check to ensure that the ACCess 2003 user are not opening them in
    "exculsive" mode, and all the users have full rights over the DB and the
    directory folder were it resides.
    I have checked everything I can think off, can anyone point me in the right
    direction.

    Cheers.
     
  2. Loading...


  3. Wayne Morgan

    Wayne Morgan
    Expand Collapse
    Guest

    You've checked the only 2 things I can think of. However, make sure you've
    checked far enough. The Exclusive could come from the default setting in
    Tools|Options or from the command line used to open the database. It can
    also come from the File|Open dialog as you open the database if the user
    uses the down arrow part of the Open button.

    When checking the share permissions for full access, make sure to check both
    the Share and NTFS permissions. If this is the problem, it should show
    consistently based on the user.

    If neither of these is the problem, then I would suspect an intermittent
    network connection. Again, unless the intermittent connection is the one to
    the server or the hub itself I would expect this to be user specific.

    --
    Wayne Morgan
    MS Access MVP


    "charlief" <charlief@discussions.microsoft.com> wrote in message
    news:7CD92BD1-C310-49F7-A357-6F350E198635@microsoft.com...
    > Hi all.
    > I am pulling my hair out, and would appriciate some help while i have some
    > hair left.
    > I have various Access DB for users to access on a server. When a user
    > opens
    > the DB there is a 60/40 change that it will not create a .ldb lock.
    > I have check to ensure that the ACCess 2003 user are not opening them in
    > "exculsive" mode, and all the users have full rights over the DB and the
    > directory folder were it resides.
    > I have checked everything I can think off, can anyone point me in the
    > right
    > direction.
    >
    > Cheers.
     
  4. charlief

    charlief
    Expand Collapse
    Guest

    Hi Wayne,
    Thanks for your reply. I have checked the permitions, both shared and NTFS,
    the group has full access to the parent folder and the DB.

    Users dont use the command line to access the DB, they either navage from
    within Access or open it directly from share drive.

    The most puzzeling this is that this is not user or version specific.
    I will have to check the switch at head office, however there has been no
    reports of intermitant connections from users open anything else on the data
    server.

    cheers

    Charlie

    "Wayne Morgan" wrote:

    > You've checked the only 2 things I can think of. However, make sure you've
    > checked far enough. The Exclusive could come from the default setting in
    > Tools|Options or from the command line used to open the database. It can
    > also come from the File|Open dialog as you open the database if the user
    > uses the down arrow part of the Open button.
    >
    > When checking the share permissions for full access, make sure to check both
    > the Share and NTFS permissions. If this is the problem, it should show
    > consistently based on the user.
    >
    > If neither of these is the problem, then I would suspect an intermittent
    > network connection. Again, unless the intermittent connection is the one to
    > the server or the hub itself I would expect this to be user specific.
    >
    > --
    > Wayne Morgan
    > MS Access MVP
    >
    >
    > "charlief" <charlief@discussions.microsoft.com> wrote in message
    > news:7CD92BD1-C310-49F7-A357-6F350E198635@microsoft.com...
    > > Hi all.
    > > I am pulling my hair out, and would appriciate some help while i have some
    > > hair left.
    > > I have various Access DB for users to access on a server. When a user
    > > opens
    > > the DB there is a 60/40 change that it will not create a .ldb lock.
    > > I have check to ensure that the ACCess 2003 user are not opening them in
    > > "exculsive" mode, and all the users have full rights over the DB and the
    > > directory folder were it resides.
    > > I have checked everything I can think off, can anyone point me in the
    > > right
    > > direction.
    > >
    > > Cheers.

    >
    >
    >
     
  5. Albert D.Kallal

    Albert D.Kallal
    Expand Collapse
    Guest

    > the DB there is a 60/40 change that it will not create a .ldb lock.
    > I have check to ensure that the ACCess 2003 user are not opening them in



    Often, with a split database, the ldb file is NOT created until a form, or
    table is actually opened.

    in fact, the above reason is why IT IS RECOMMEND that you force a persistent
    connection in your startup form/code. This way, that VERY slow process of
    connecting and making the ldb file does not occur over and over. This
    "trick" in fact can speed up your appcation dramatically, and eliminate some
    serious delays when in a multi-user environment.

    And, this also means that your front end if it closes all tables (and forms
    that are bound) will cause the ldb file (for the back end) to disappear. At
    this point you can even run code in the front end that compacts the back
    end...

    --
    Albert D. Kallal (Access MVP)
    Edmonton, Alberta Canada
    pleaseNOOSpamKallal@msn.com
    http://www.members.shaw.ca/AlbertKallal




    > "exculsive" mode, and all the users have full rights over the DB and the
    > directory folder were it resides.
    > I have checked everything I can think off, can anyone point me in the
    > right
    > direction.
    >
    > Cheers.
     

Share This Page